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1.1 In This Guide
1.1.1 The 55451A open synchronization management framework (OSMF) System 
Administrator�s Guide provides information necessary to manage and maintain the OSMF 
hardware and software.  It makes the assumption you have experience with the Windows NT 
operating system, HP OpenView, and Oracle database administration.

1.1.2 This guide includes the following topics:

� Features supported in the current version of the software as well as a modular description of 
the software

� Responsibilities of the system administrator
� Basic system administration tasks, such as starting and stopping the software, and routine 

system administration
� OSMF user management
� System backup and recovery
� Installation of OSMF software and software upgrades
� Commissioning of SSUs

1.1.2.1 Naming Conventions Used in this Guide
This guide uses several names to refer to the same objects.  The usage of multiple terms for the 
same object helps define the relationship between objects in different situations.  To establish 
naming conventions, the objects and their corresponding names are listed in the following table:

1.2 Description of the OSMF Software
1.2.1 The OSMF software provides an easy-to-use graphical user interface (GUI) for the 
management of SSUs that make up the synchronization network.  SSUs are managed via a 
network connection between the management system and each SSU.  Once this connection is 
established, the OSMF software can be used to modify the topology of the synchronization 
network, and manage the configuration of the individual SSUs in the network.  Version 3.0 of the 
OSMF software also provides limited capacity to manage primary reference sources (GPSs) in 
the network.

Object Names Used for the Object

55451A open synchronization management 
framework software

OSMF software for Windows NT, OSMF 
software, OSMF

Personal Computer hardware OSMF Management Server, OSMF Management 
Client, OSMF Management Console, OSMF 
workstation, OSMF computer, OSMF system, 
management system, element manager

55400A synchronization supply unit SSU, NSU, network element, network object

55300A primary reference source PRS, GPS, network element, network object
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1.2.1.1 Features of the OSMF Software - Version 3.0
Standard Edition - The following features are included in the standard edition of version 3.0 of 
the OSMF software for Windows NT:

� Support for up to four Management Consoles (also referred to as Management Clients).
� Network communications with SSUs using either the TCP/IP network protocol or the X.25 

network protocol.
� Single-screen graphical representation of the synchronization network topology, with color 

coding to indicate the severity of alarms originating at SSU nodes within the network.
� Limited capacity to manage primary reference sources (GPSs) in the network. GPSs can be 

symbolically represented on the topology maps, with color coding to indicate the severity of 
alarms originating from them.  Alarms emanating from GPS nodes will also be viewable in 
the Alarm Viewer.  The total number of network elements (GPSs and SSUs) that can be man-
aged by the OSMF software is 50.

� Display of synchronization trails that represent the connectivity between network elements.  
If a problem exists with the signal path represented by the sync trail symbol, the color of the 
symbol will change to indicate the nature of the problem.

� The ability to manage multiple system users in three different user classes, which determine 
the level of capability that each user has when using the system.

� A Network Element Status display, which can be used to remotely view the status of selected 
panel indicators on the various boards of a specified SSU.

� An Alarm Viewer, which provides alarm/event sorting and filtering capabilities and the abil-
ity to obtain more detail on alarms or events emanating from SSUs.

� Alarm auto-synchronization tasks that ensure that the list of alarms displayed in the Alarm 
Viewer dialog box match the outstanding alarms in the SSUs.

� The ability to collect and graphically display performance data for a variety of SSU input 
channel measurement types, including the ability to set masks and measurement thresholds.

� The ability to produce formatted event reports and performance reports that can be printed 
on a system printer.

� Inventory management, that allows for the management of a master database of the various 
hardware resources available in the network.

� The ability to modify the configuration of any SSU that is actively being managed by the 
software.

� A heartbeat task, which provides automatic, periodic checking of the connectivity to all man-
aged SSUs.

� An auto-alignment task which ensures that the SSU configuration information contained in 
the OSMF database is aligned with the actual configuration of the SSUs.

� An event forwarder, which allows Element Manager integration with upper-layer manage-
ment systems.

� On-line help, which affords easy access to task, feature, and troubleshooting information via 
an on-screen display.

Deluxe Edition - The following additional features are included in the deluxe edition of version 
3.0 of the OSMF software for Windows NT:
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� A choice of either HP OpenView Windows (OVW) or OSMF status propagation rules to 
indicate changes in status of network elements at the lower levels of the containment hierar-
chy.

� Management domains, which specify the network elements that a given user can access.
� A transaction log, which includes a record of transactions between users and the system, as 

well as certain internal system transactions. The Security-class user has the ability to view 
the transaction log and produce formatted transaction log reports that can be printed on a 
printer.

� The ability to create SSU users, and set the date and time on SSUs, remotely from the OSMF 
system.

� The ability to create and store one or more default SSU configurations.  These default con-
figurations, which are stored in the database, can then be downloaded to SSUs when the 
SSUs are managed or remanaged.

� The ability to download the configuration of a previously managed SSU to another SSU 
when that SSU is managed or remanaged.

� The ability to download firmware code from the OSMF system to the EPROMs within tar-
geted SSUs.

1.3 OSMF Software System Overview
1.3.1 The OSMF software is integrated with the HP OpenView Network Node Manager (NNM) 
platform to present a graphical user interface (GUI) to the topology of the synchronization 
network as well as to the management of those network elements (SSUs and GPSs) that comprise 
the network.  A Windows NT-based OSMF system installation can consist of one Management 
Server (required) and up to four Management Consoles (also known as Management Clients).

Management Servers and Management Consoles both provide GUI services as well as TL1 
Request/Response communications (transaction handling) between themselves and network 
elements in the synchronization network.

In addition, the Management Server contains the OSMF database, and provides synchronization 
services (configuration alignment, hardware alignment, and alarm synchronization), Event 
receiving and processing services (event handling), and status handling.  The Management 
Server acts as the repository for System Information (topology, event, inventory, user domain, 
and configuration information), and this information is shared between the Management Server 
and Management Consoles via the network connection.
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The following figure shows a simplified block diagram of an installed OSMF system consisting 
of one Management Server and two Management Consoles:

Following is a block diagram of the Management Server software.
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Following is a block diagram of the Management Client software.

NOTE The software modules shown in the block diagrams above and described below do not 
necessarily represent actual OSMF software processes.

1.3.1.1 Transaction and Event Handling
The OSMF system software can be thought of as having two main functions: transaction 
handling and event handling.  Transaction handling takes place on Management Clients as well 
as the Management Server, and involves the processing of command transactions (request-and-
response actions) between the OSMF software and the SSUs in the synchronization network.  
Event handling takes place on the Management Server and involves the processing of alarms and 
other events from the SSUs and GPSs.

The software modules involved in Event Handling include the Event Receiver, Event Processing 
Engine, Alert Dispatcher, Fault Management Forms, and Network Map.  The following describes 
the function of these modules.

� Event Receiver - The Event Receiver receives events from the managed as well as unman-
aged SSUs and GPSs in the synchronization network and forwards only valid events from 
managed SSUs and GPSs to the Event Processing Engine.
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� Event Processing Engine - The Event Processing Engine receives events from the Event 
Receiver and determines their status and type.  Depending on the status and type of an event, 
the Event Processing Engine logs the event into the appropriate event database table and if 
necessary sends an alert message to the Alert Dispatcher (alert messages result from events 
that signal a change of status in SSUs or GPSs).  The Event Processing Engine also passes 
events on to the appropriate Fault Management Forms, and to Management Clients, so that 
the events can be displayed in the client�s Fault Management Forms.

� Alert Dispatcher - The Alert Dispatcher receives alert messages from the Event Processing 
Engine.  It then sends status update information as appropriate to the Network Maps in each 
of its registered sessions of OSMF software, and passes status update information to Man-
agement Clients, so that status can be updated in the client�s Network Maps.

� Network Maps - These are graphical representations of the synchronization network.  Net-
work Maps are created using the OSMF software and are comprised of either actively man-
aged or unmanaged SSU and GPS objects (icons).  Management Servers as well as 
Management Clients display and provide map modification services, however, the topology 
information that is displayed in the maps is managed on the Management Server.

� Fault Management Forms - These are the user interfaces to the fault management functions 
of the OSMF software.  The fault management forms are the Network Element Status, Alarm 
Viewer, and Event History Log, and Transaction Log forms.  Fault management information 
is typically processed by the Management Server, and passed on to Management Clients for 
presentation.  Since there can be several registered sessions of the OSMF software, there can 
be multiple active fault management forms.  Specifically, there can be up to two Alarm 
Viewers or Event History Logs open per OVW session (note that the Alarm Viewer can be 
invoked via the Network Element Status form).  There is no limit on the number of Network 
Element Status forms open per OVW session, however, no more than one per SSU is recom-
mended.

The software modules involved in Transaction Handling include the Communications Interface, 
Object-Oriented Command Processing Engine, Security Service, Security Forms, Configuration 
Forms, Performance Forms, and Inventory Forms.  The following describes the function of these 
modules.

� Communications Interface - The Communications Interface handles the connection and 
message transport operations between the OSMF platform and the remote interface of the 
SSUs.  It receives TL1 requests from the Command Processing Engine and sends them to the 
SSUs as well as receives TL1 responses from the SSUs and sends them to the Command 
Processing Engine.

� Object-Oriented Command Processing Engine - The Command Processing Engine han-
dles transactions (request/response actions) between OSMF software processes and SSUs.    
On Management Clients, the Command Processing Engine interfaces directly between vari-
ous OSMF forms or processes and SSUs, and passes any resultant database change informa-
tion to the Management Server.  On the Management Server, the Command Processing 
Engine might interface with the configuration database, or with SSUs, depending on the 
nature of the transaction.  As an example, if a Management Server process requests the cur-
rent configuration of an SSU, the Command Processing Engine will extract the necessary 
information from the database if it�s available, or it will generate and pass the necessary TL1 
commands to the Communications Interface in order to retrieve the configuration informa-
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tion from the SSU.  When handling a response, the Command Processing Engine receives 
the TL1 response from the Communications Interface, extracts the necessary information, 
and appropriately processes it (passes the response data to the requesting process, updates 
the database, etc.).

� Security Service - The Security Service provides security management functions for the 
OSMF software.

� Security Forms - These are the user interfaces to the security management functions of the 
OSMF software.  The current software release contains one security form, called the Man-
agement Domain form.  Management domains can be created or modified on any system 
(Management Clients or the Management Server), but user verification takes place on the 
Management Server.  There can be no more than one Management Domain form open per 
OVW session.

� Configuration Forms - These are the user interfaces to the configuration management func-
tions of the OSMF software.  The configuration forms include the current SSU configuration 
forms, the default configuration management forms, and the Firmware Download form.

Since there can be several registered sessions of the OSMF software, there can be multiple 
active Configuration forms.  Specifically, there can be no more than one 
Configuration:Modify form open per SSU (no more than two per OVW session is 
recommended).  No more than two Configuration:View forms per OVW session is 
recommended.

� Performance Forms - These are the user interfaces to the performance management func-
tions of the OSMF software.  The software contains one performance form, called the Per-
formance Monitor.  Since there can be several registered sessions of the OSMF software, 
there can be multiple active Performance forms.   Specifically, there should be no more than 
one Performance Monitor form open per SSU (no more than two per OVW session is recom-
mended).

� Inventory Forms -  These are the user interfaces to the inventory management functions of 
the OSMF software.  The inventory forms include the Inventory, Output Card Inventory, and 
Rack Inventory form.  Since there can be several registered sessions of the OSMF software, 
there can be multiple active Inventory forms.  Specifically, it is recommended that there be 
no more than two Inventory forms open per OVW session (note that the Rack Inventory 
form can be invoked via the Configuration forms).
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1.3.1.2 Synchronization Processes
One of the key functions of the OSMF software is the continued assurance that the SSU and GPS 
information as stored in the OSMF database is synchronized with the relevant information in the 
SSUs and GPSs that comprise the synchronization network.  The OSMF software uses several 
software processes to assure that this synchronization is maintained.  Synchronization processes 
run on the Management Server.  These processes ensure synchronization is maintained by 
monitoring the four flags described below:

The following paragraphs explain the configuration synchronization processes used by the 
OSMF software:

Heartbeat Daemon

A Heartbeat task, also known as the Heartbeat daemon, periodically checks each network 
element, that is each SSU and GPS, to determine the following:

� Whether or not the SSU or GPS is available.
� For SSUs, Whether or not the hardware configuration of the SSU is aligned with its hard-

ware configuration as stored in the database.
� For SSUs, Whether or not the SSU�s configuration information is aligned with its configura-

tion information as stored in the database.

In operation, the Heartbeat task sequentially goes through the list of managed network elements 
(NEs) in the OSMF database and performs the following functions on each NE in sequence:

1 If the NE is an SSU, The Heartbeat task first checks whether or not the �hw_aligned� flag for the 
SSU is set to TRUE.  If the flag is set to TRUE, it continues on with step 2 (below) for the same 
SSU.  If it discovers that the �hw_aligned� flag is set to FALSE, it invokes a process called 

Flag Description

available This flag is set to TRUE when the OSMF software�s Heartbeat Daemon (explained 
below) is able to send a command to and receive a response from the SSU or GPS.  (If 
an SSU or GPS is found to be unavailable, it is also assumed that it is unaligned, and 
both the �available� and �aligned� flags are set to FALSE.)

managed This flag is set to TRUE when the OSMF software is currently managing the SSU or 
GPS.  Network elements are managed and unmanaged from the �OSMF� menu.

aligned This flag is set to TRUE when the SSU�s configuration information is aligned with its 
configuration information as stored in the OSMF database.

hw_aligned This flag is set to TRUE when the hardware configuration of the SSU is aligned with 
its hardware configuration as stored in the OSMF database



Chapter 1  Introduction and General Information

OSMF Software System Overview

1-10 55451A OSMF Software System Administrator’s Guide

097-55451-04

Issue 1

�check_hw_align� (refer to Hardware Alignment, below), then performs step 1 for the next NE 
record stored in the database.

If the NE is a GPS, the Heartbeat task sends it the �RTRV-HDR� TL1 command to determine if 
it is available.  If the GPS responds to the �RTRV-HDR� command, the Heartbeat task sets the 
�available� flag in the database for the GPS to TRUE, then performs step 1 for the next NE 
record in the database.  If the GPS does not respond to the �RTRV-HDR� command, the 
Heartbeat task sets the �available� flag in the database for the GPS to FALSE, then performs step 
1 for the next NE record in the database.

2 If the �hw_aligned� flag for the SSU is set to TRUE, the Heartbeat task attempts to retrieve the 
time that the SSU was last configured (the last_config_time) from the SSU.  If it is successful in 
retrieving the last_config_time, it then compares this value to the last_config_time that is stored 
in the database for the SSU.  The following table explains the SSU condition ascertained by the 
Heartbeat task from the comparison, as well as the action taken by the Heartbeat task:

The �aligned� and �available� database flags that are set by the Heartbeat task are subsequently 
used by the Alignment daemon (refer to Alignment Daemon, below).

NOTE In the current version of the OSMF software, the heartbeat is sent out to all Network Elements 
every 20 seconds.

Alignment Daemon

An SSU Alignment task, also known as the Alignment daemon, periodically goes through the list 
of SSUs in the OSMF database identifying SSUs for which the �aligned� flag is set to FALSE, 
and the �available� and �managed� flags are set to TRUE.

Heartbeat Task can 
Retrieve last_config_time 
from the SSU?

The last_config_time in 
Database Matches 
last_config_time from the 
SSU? Condition and Action

Yes Yes Network Element is Available and Aligned.
The Heartbeat task goes to the next NE record stored in 
the database, and performs step 1 as explained above.

Yes No Network Element is Available, but Unaligned.
The Heartbeat task sets the �aligned� flag in the database 
for the SSU to FALSE, then goes to the next NE record 
stored in the database, and performs step 1 as explained 
above.

No N/A Network Element is Unavailable.
The Heartbeat task sets the �available� flag as well as the 
�aligned� flag in the database for the SSU to FALSE, 
then goes to the next NE record stored in the database, 
and performs step 1 as explained above.
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When an SSU is identified as having its �aligned� flag set to FALSE and its �available� and 
�managed� flags set to TRUE, the Alignment task acquires a database lock on the SSU to 
prevent other processes from attempting to realign it or modify its configuration during the 
realignment process.  After the database lock is procured, the Alignment task goes through the 
following sequence:

� The local port on the SSU is disabled.
� The SSU�s configuration is uploaded to the database.
� The �aligned� flag is set to TRUE for the SSU.
� The last_config_time is set at the SSU, then uploaded to the database.
� The local port is re-enabled if it was enabled before the start of re-alignment.
� The database lock is released for the SSU.

NOTE If, during the database walkthrough, the Alignment task discovers unaligned SSUs that are either 
unmanaged or unavailable, it does not act on them, however, they are checked again the next 
time the database is walked through by the Alignment task.

If the Alignment task cannot procure a database lock because the SSU has already been locked, it 
returns an error which explains the reason for the failure (whether it is already being re-aligned, 
or modified).  In this case, the SSU will be aligned as soon as the Alignment task walks through 
the database and discovers that the SSU is available, managed, and not locked.

Alarm Synchronization

The OSMF software obtains a list of active alarms from each SSU and GPS and compares these 
with the alarms in its database, which are the alarms shown in the Alarm Viewer dialog box.  
During this comparison, any alarms that are in the database (still active in the Alarm Viewer) but 
are no longer active in an SSU or GPS are considered expired.  Once alarms have expired, they 
are transferred from the Alarm Viewer dialog box to the Event History Log dialog box.

NOTE In the current version of the OSMF software, the alarm synchronization process repeats every 12 
hours.

Hardware Alignment

Whenever the hardware configuration of an SSU is modified (as when certain boards are either 
added or removed), the following events are generated by the SSU, as relevant:

� OPCDIN  (an output card has been inserted into a slot)
� OPCDNP  (a previously-detected output card has been removed from its slot)
� ITHGONE  (an ITH card is missing)

Whenever any of these events are received by the OSMF software for a given SSU, the OSMF 
software sets the �hw_aligned� flag for the SSU to FALSE.
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As previously stated under Heartbeat Daemon, above, the Heartbeat task checks the state of the 
�hw_aligned� flag, and if it discovers that the flag is set to FALSE, it invokes a process called 
�check_hw_align.�  The �check_hw_align� process determines the actual state of hardware for 
the SSU, and acts accordingly.

� If  �check_hw_align� determines that the hardware is unaligned because of the addition of 
boards, it updates the rack inventory and output card inventory database tables accordingly 
with the relevant information, and then sets the �hw_aligned� flag to TRUE.

� If  �check_hw_align� determines that the hardware is unaligned because output cards have 
been deleted, it does not change the �hw_aligned� flag, so it remains set to FALSE.  Instead, 
it generates a secondary event, called �Secondary Event - Configurable Units Removed,� or 
SE-CFGRM (which has a severity of Critical).

In the case where the SE-CFGRM event is generated, the �Configuration:Modify� dialog box 
presents a warning dialog box to the user informing that a reduction in the number of output 
cards has been detected, and prompts the user as to whether or not the output card records should 
be deleted from the database.  When the user elects to delete the cards from the database, the rack 
inventory and output card inventory database tables are updated, commands are issued to the 
SSU to remove the cards from its inventory, the SE-CFGRM event is cleared, and the 
�hw_aligned� flag is set to TRUE.

1.4 System Requirements
1.4.1 The following is required to run the 55451A OSMF software.

1.4.1.1 OSMF Management Server System Requirements
The OSMF Management Server software requires a Pentium-class computer system running the 
Microsoft Windows NT operating system.  The following is the recommended configuration:

� Pentium-class computer system with 200 MHz processor (or above - Pentium-II processor 
recommended)

� 192 MB RAM (256 MB RAM recommended)
� 600 MB of hard disk space
� Hard drive partitioned as an NTFS file system
� CD-ROM Drive (if software installation will take place from a CD)
� Microsoft Windows NT Server version 4.0 operating system, configured as a Primary 

Domain Controller
� Microsoft Windows NT version 4.0 Service Pack 3
� HP OpenView Network Node Manager version B.05.02
� Patch �NNM_00085� for the HP OpenView Network Node Manager
� Oracle 8 release 8.0.4.0.0 for Windows NT (typical installation)
� Oracle Developer/2000 release 2.1 for Windows NT (typical installation)
� Oracle Developer/2000 patches (patch index 573), as follows:

� Oracle Forms Runtime Version 5.0.6.10.0 for Windows NT
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� Oracle Reports Runtime Version 3.0.5.9.0 for Windows NT
� Microsoft Internet Explorer version 4.0 (for On-Line Help)
� Adobe Acrobat Reader version 4.0 (for On-Line Help)

1.4.1.2 OSMF Management Console System Requirements
The OSMF Management Console (�Management Client�) software requires a Pentium-class 
computer system running the Microsoft Windows NT operating system.  The following is the 
recommended configuration:

� Pentium-class computer system with 200 MHz processor (or above - Pentium-II processor 
recommended)

� 64 MB RAM (128 MB RAM recommended)
� 50 MB of hard disk space
� Hard drive partitioned as an NTFS file system
� CD-ROM Drive (if software installation will take place from a CD)
� Microsoft Windows NT Workstation version 4.0 operating system
� Microsoft Windows NT version 4.0 Service Pack 3
� HP OpenView Network Node Manager (Client Console) version B.05.02
� Patch �NNM_00085� for the HP OpenView Network Node Manager
� Oracle Developer/2000 release 2.1 for Windows NT (typical installation)
� Oracle Developer/2000 patches (patch index 573), as follows:

� Oracle Forms Runtime Version 5.0.6.10.0 for Windows NT
� Oracle Reports Runtime Version 3.0.5.9.0 for Windows NT

� Microsoft Internet Explorer version 4.0 (for On-Line Help)
� Adobe Acrobat Reader version 4.0 (for On-Line Help)

1.4.1.3 Hardware Requirements for SSUs
To be managed by the 55451A OSMF software, an 55400A Synchronization Supply Unit must 
include one of the following Network Information Management (NIMC) cards:

� 55452A NIMC card (standard configuration) to support TCP/IP connectivity.

� 55452A Option 002 NIMC card to support X.25 connectivity.

NOTE The current version of 55451A OSMF software does not support TP-4 connectivity.

1.5 System Performance
1.5.1 In general, system performance will be adequate for most situations when the OSMF 
software is the only application running on the system.  There are, however, several ways in 
which system performance can be boosted if that becomes necessary or is desired.
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1.5.1.1 Memory
The RAM specifications shown in the System Requirements section above are considered 
minimum requirements for normal system installations.  If other applications will be running on 
the system concurrently with the OSMF application, or if a large number of network elements 
will be managed by the system, more memory likely will be needed for optimum performance.

In general, enough memory should be installed such that the system does not memory-swap.  
You can monitor how much memory-swapping is occurring using the system�s performance 
monitor.  To monitor memory-swapping:

1 Choose Start ⇒ Programs ⇒ Administrative Tools ⇒ Performance Monitor.

2 Choose Add to Chart... from the Performance Monitor�s �Edit� menu.

3 In the �Add to Chart� dialog box, select Memory in the �Objects� drop-down list, then while 
holding down the Ctrl key, select both Pages/sec and Available Bytes in the �Counter� scroll-
box, and click the Add button.

The graphs displayed in the performance monitor will help you determine the amount of 
memory-swapping going on, and how much memory is available (for an explanation of the data 
being displayed in the performance monitor, double-click on the legend at the bottom of the 
performance monitor, then click the Explain >> button in the dialog box that appears).

1.5.1.2 Tasking Model
Foreground applications should be given highest performance priority, as this will make the 
Graphical User Interfaces most responsive:

1 Choose Start ⇒ Settings ⇒ Control Panel, then double-click on the �System� icon.

2 In the �System Properties� dialog box, click the �Performance� tab, then slide the �Application 
Performance� slider to �Maximum.�

1.5.1.3 Video Performance
The OSMF application is a very graphical application.  Installation of a high quality video card 
will yield better performance for operations like panning and zooming.

1.5.1.4 Network Throughput
On Management Servers, you can maximize network throughput for network applications.

1 Choose Start ⇒ Settings ⇒ Control Panel, then double-click on the �Network� icon.

2 In the �Network� dialog box, click the �Services� tab, select Server under �Network Services,� 
then click the Properties... button.

3 Click on the �Maximize Throughput for Network Applications� radio button so that it is 
selected, then click OK.



Chapter 1  Introduction and General Information

Responsibilities of the System Administrator

55451A OSMF Software System Administrator’s Guide 1-15

097-55451-04

Issue 1

This setting optimizes the server�s memory for distributed applications that do their own memory 
caching.

1.5.1.5 Additional Information
A good discussion on tuning a Windows NT system can be found on the Microsoft TechNet CDs.  
The article, entitled Optimizing and Tuning of Windows NT, discusses using the operating 
system�s performance monitor, optimizing system memory, the processor, and I/O system 
resources.  The Microsoft TechNet service, which includes the TechNet CDs, is available from 
Microsoft.

1.6 Responsibilities of the System Administrator
1.6.1 The system administrator is responsible for maintenance of the OSMF system.  This 
requires the system administrator to understand both the hardware and the software installed in 
the system.

1.6.2 The main responsibilities of the system administrator are as follows:

� Creation and management of OSMF system users.
� Periodic backup of system files and the system database.
� Archival of event log, transaction log, and performance data files.
� Updates to the operating system and OSMF software when necessary.
� Implementation of system security measures.

CAUTION The security-level (�svsec�) user has the potential to cause data loss or corruption of the network 
topology.  Users of the security-level class have the ability to modify network topology, 
configuration settings, management status of SSUs, etc.  It is the responsibility of the system 
administrator to secure the OSMF system against unintentional and unauthorized operation.

1.7 Prerequisite Knowledge
1.7.1 As stated previously, the procedures in this manual assume you have Windows NT, HP 
OpenView, and Oracle database administration experience.

1.8 Related Documentation
1.8.1 In some cases, procedures in this guide might refer you to procedures or other information 
contained in documentation that includes the SSU documentation (55400 Synchronization 
Supply Unit Site Preparation Guide and 55400 Synchronization Supply Unit User�s Manual), 
GPS documentation, Windows NT documentation, and HP OpenView documentation.
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2.1 In this Chapter
2.1.1 The procedures in this chapter explain how to start and stop an OSMF software session. 
Performing these tasks are often necessary prior to performing other system administration tasks.
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2.2 To Start an OSMF Software Session
2.2.1 Use the following procedure when initiating a session of the OSMF software.  Note that all 
steps might not be necessary, for example, the OSMF system might already be powered on.  The 
general procedure is as follows:

� Power up the OSMF system and log into Windows NT.
� Start the Oracle database, if necessary.
� Ensure that all necessary OSMF software daemons are active.
� Start the OSMF software operator session.

CAUTION Once you have initiated an OSMF software session using the following procedure, be aware that  
you must correctly stop the session using the procedure in this chapter.  Failure to correctly end 
the session might result in corruption of system data or data loss.

2.2.1.1 Power up the OSMF system.
If the OSMF system has already been powered up, go to Start the Oracle database (if necessary).  
Note that you must be logged into Windows NT as �svroot� to start the Oracle database.

1 Set the power switches on the monitor and OSMF system to on.  The power indicators light when 
power is switched on.

As the system starts up, it runs a series of checks during which numerous messages and screen 
changes occur.  Once the start-up sequence is complete, a box containing the message �Press 
Ctrl + Alt + Delete to log on� appears.

2 Simultaneously press the Ctrl, Alt, and Del keys, then enter the following information in the 
�Logon Information� box that appears:

� User Name field - Enter svroot if it does not already appear in this field.
� Password field - Enter the password of the svroot user.
� Domain - Ensure that the domain name of the Management Server is selected.

NOTE Initially, user svroot does not have a password assigned.  If you have not yet assigned a password 
to user svroot, leave the Password field blank for this step.

It is advisable to assign a password as soon as possible.  Refer to the procedure entitled To 
Modify a System User in the chapter entitled Routine OSMF System Administration for details on 
assigning a password to the svroot user as well as other users.

3 Click OK to start the log-in process.

After the login is complete, the Windows NT desktop appears.
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2.2.1.2 Start the Oracle database (if necessary).
The Oracle database is normally started upon power-up of the OSMF system, however, if the 
system had previously been powered up, the Oracle database might have subsequently been shut 
down.  The following procedure can be used to check if it is running, and start it if necessary.

1 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ System Monitor to 
check if the Oracle database is running.

The information in the System Monitor should suggest that the Oracle database is running.  If the 
Oracle database is running, �Oracle TNSListner80� and �OracleServiceSV30� will 
have an indicated status of RUNNING.

If the System Monitor indicates the status of �Oracle TNSListner80� and 
�OracleServiceSV30� as RUNNING, go to Start HP OpenView and the necessary OSMF 
software processes. If the System Monitor indicates the status of �Oracle TNSListner80� 
and �OracleServiceSV30� as STOPPED, continue with the next step.

2 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Database Services 
- Start to start the Oracle database.

As the database is starting, a �svdbstart� terminal window appears which displays some status 
messages.  After the database startup process is complete, the �svdbstart� terminal window 
closes.

3 Re-check the status of �Oracle TNSListner80� and �OracleServiceSV30� in the 
System Monitor.

They should now have a status of RUNNING.

2.2.1.3 Start HP OpenView and the necessary OSMF software processes.
The HP OpenView and OSMF software processes normally are started upon power-up of the 
OSMF system, however, if the system had previously been powered up, they might have 
subsequently been shut down. The following procedure can be used to check if they are running, 
and start them if necessary.

NOTE The Oracle database must be running before the OSMF software processes are started.  If an 
attempt was made to start the OSMF software processes while the Oracle database was down, the 
following procedure will need to be performed again to start them after the Oracle database is 
started.

1 Check the status of the OSMF software processes in the System Monitor.

If the OSMF software processes are running, and they were started after the Oracle database 
was started, the following will be shown in the System Monitor:
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OpenView/Oracle Service Status:
   OpenView Process Manager   RUNNING
   OracleServiceSV30             RUNNING
   Oracle TNSListner80           RUNNING

OSMF Daemon Status:
   ovwdb       RUNNING
   pmd         RUNNING
   svalert     RUNNING
   svalign     RUNNING
   sveht       RUNNING
   svgpsfea    RUNNING
   svhb        RUNNING
   svovwcom    RUNNING
   svss        RUNNING

If the System Monitor indicates that �OpenView Process Manager� and all OSMF 
daemons are RUNNING, go to Start the OSMF Software Operator Session. If the System Monitor 
indicates that �OpenView Process Manager� is STOPPED, or if �OpenView Process 
Manager� is RUNNING but some daemons are NOT_RUNNING, continue with this procedure.

NOTE The Oracle database must be running before performing the next step.

2 Choose Start ⇒ Programs ⇒ OSMF ⇒ OSMF Manager ⇒ OSMF Services - Start to 
start the HP OpenView and OSMF software processes.

When the OSMF Services startup procedure commences, an �OSMF Services - Start� dialog box 
appears.  Note that the Restart button in the dialog box is de-emphasized (�grayed out�) at that 
point.  As each process starts, it appears in the dialog box. After all processes have started, the 
Restart button becomes active (emphasized).

3 After the HP OpenView and OSMF software processes start, click the Close button in the 
�OSMF Services - Start� dialog box to close it.

4 Re-check the status of the HP OpenView and OSMF software processes.

The System Monitor should now indicate that �OpenView Process Manager� and all 
OSMF daemons are now RUNNING.

5 Close the System Monitor.
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2.2.1.4 Start the OSMF Software Operator Session.
1 Perform the following steps to log into Windows NT as either a �Security,� �Administrator,� or 

�User� class user:

a. Choose Start ⇒ Shut Down...
b. In the �Shut Down Windows� box that appears, select the �Close all programs and 

log on as a different user� radio button, then click the Yes button.

c. When the box containing the message �Press Ctrl + Alt + Delete to log on� 
appears, simultaneously press the Ctrl, Alt, and Del keys.

d. Log in with the appropriate user name and password.

The user group (Security, Administrator, or User) to which the user logon belongs determines the 
level of capability that the user is granted when using the system. The section entitled User 
Classes in Chapter 1 of the 55451A OSMF Software User�s Guide explains in more detail exactly 
which tasks can be performed by users of given user classes.

NOTES The OSMF system ships with one Security-class user created, and this user has the logon name 
�svroot.� All subsequent users need to be created in the appropriate user group before they can 
log in. If a given user has not yet been created, refer to the section entitled OSMF User 
Administration in the Routine OSMF System Administration chapter of this manual for 
information on how to create the user.

If a Windows NT user that is not a member of one of the three OSMF user groups attempts to 
start an OSMF operator session, a FATAL error (�Failed to connect to Oracle 
database�) will occur.

2 Choose Start ⇒ Programs ⇒ OSMF ⇒ User Map Session to start the OSMF operator 
session.

When the OSMF session starts, the main �Root� map will be displayed on the monitor.  It might 
appear similar to the following.

NOTE When the map first appears, its menus, etc., will not be synchronized. Do not begin using the 
OSMF software until after synchronization is complete. Synchronization is complete after the 
word �Synchronizing� appears in the status area at the bottom of the map window, for example:

default [Read-Write] [Synchronizing]    For the �svroot� user.
   or
default [Read-Only] [Synchronizing]     For other users.

then disappears.
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2.3 To Stop an OSMF Software Operator Session
2.3.1 Use the following procedure to stop an OSMF operator session.

CAUTION You must correctly end the session using the following procedure.  Failure to correctly end the 
session might result in corruption of system data or data loss.

� In the main operator session screen, choose Exit from the �Map� menu, then click OK in the 
�OpenView Windows WARNING� box when it appears.

After the OSMF operator session ends, the operator session screens disappear.

2.4 To Stop the OSMF Software and Database
To perform system maintenance, such as system backup, you might need to shut down the OSMF 
software and related Oracle processes.  When the system is properly shut down using the 
Start ⇒ Shut Down... menu, the software and related processes are brought down gracefully.  
If you need to shut down the software and related processes, but not the system, you can use the 
following steps:

1 Perform the following steps to log in as user svroot:

a. Choose Start ⇒ Shut Down...
b. In the �Shut Down Windows� box that appears, select the �Close all programs and 

log on as a different user� radio button, then click the Yes button.

c. When the box containing the message �Press Ctrl + Alt + Delete to log on� 
appears, simultaneously press the Ctrl, Alt, and Del keys.

d. Log in as the svroot user, and enter the svroot password.

2 Choose Start ⇒ Programs ⇒ OSMF ⇒ OSMF Manager ⇒ OSMF Services - Stop to 
shut down the software and related processes.

When the OSMF Services shutdown procedure commences, an �OSMF Services - Stop� dialog 
box appears.  Note that the Restart button in the dialog box is de-emphasized (�grayed out�) at 
that point.  As each process is shut down, it appears in the dialog box. After all processes have 
been shut down, the Restart button becomes active (emphasized).

3 After the HP OpenView and OSMF software processes have been shut down, click the Close 
button in the �OSMF Services - Stop� dialog box to close it.

4 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Database Services 
- Stop to stop the Oracle database.
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As the database is being shut down, a �svdbshut� terminal window appears which might display 
some status messages.  After the database shutdown process is complete, the �svdbshut� terminal 
window closes.

5 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ System Monitor to 
check the status of the OSMF software processes.

The Status Monitor should indicate that �OpenView Process Manager,� 
�OracleServiceSV30,� and �Oracle TNSListner80� are STOPPED.

6 Close the System Monitor.
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3.1 In this Chapter
3.1.1 The following procedures are included in this chapter:

� To Create a System User
� To Modify a System User
� To Delete a System User
� To View the System Monitor
� To View or Print the System Monitor Event log
� To Start One of the Windows NT Troubleshooting Tools
� To Archive Performance History Data, Events, and Transactions
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3.2 OSMF User Administration
3.2.1 The �User Manager� dialog box is used to manage (create, modify, or delete) OSMF 
system users.  The following figure and accompanying descriptions briefly explain the �User 
Manager� dialog box: 

This area shows the user that is currently logged on and the logon domain 
name.  Note that only the �svroot� user has OSMF user administration 
privileges.
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The procedures in this section explain how to create new system users, modify user profiles, and 
delete users from the system.

3.2.1.1 To Create a System User

NOTE The OSMF database must be running in order to perform the following task.  If the database is 
not currently running, choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ 
Database Services - Start to start it.

This area displays information on the users that are currently created for the 
system.  The presence of one of the four symbols (below) in the �NT� or 
�DB� column indicates that the corresponding user exists in some capacity 
for the operating system (NT) and OSMF database (DB).  The symbol type 
indicates the current status of the user.  No symbol in the column indicates 
that the user is not created for the corresponding entity.  The legend below 
explains the meaning of the symbols:

X = User is committed to the database.
N = User has been created but is not yet committed to the database.
~ = User profile has been modified, but modifications are not yet committed.
! = User has been deleted, but deletion is not yet committed.

These buttons are used to create, modify, or delete the system users.  
Clicking the Add... button invokes a sub-box in which you enter information 
for a user to be created for the system.  To modify a system user, select the 
user in the user list, click the Modify... button, and enter the modifications in 
the sub-box that appears.  To delete a system user, select the user in the user 
list, and click the Delete button.  Clicking the Clone button clones the NT 
user selected in the user list as a database user, or vice-versa.

The radio buttons under �Account option� are used to specify whether the 
user administration operation takes place for both the NT and database users, 
or for database users only.

Clicking the Update Now button, then Yes in the confirmation box that 
follows, commits changes that have been made in the dialog box to the 
database.  The Undo button is used to undo changes made to the user 
selected in the user list, if those changes have not been committed to the 
database.  Clicking the Undo All button rolls back all changes that have not 
been committed to the database.  The Reload button is used to reload the 
user information that is stored in the database to the user list area.
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1 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ User Manager to 
call up the User Manager dialog box.

When the dialog box first appears, the message �Loading user... Please wait� 
appears in the user list area.  Eventually, the list of users appears in the user list area.

2 Choose the appropriate account option.

Select the �Make changes to both NT and OSMF-DB user accounts� radio button to create the 
user for both Windows NT and the database, or the �Make changes to OSMF-DB user accounts 
only� radio button to create the user only for the database.

3 Click the Add... button to call up the Add New User dialog box.  The Add New User dialog box 
appears as follows:

4 Enter the following information into the Add New User dialog box:

Field Description

Username Enter a unique user name.  The user name is used to identify the user account.  The user 
name can contain up to 8 upper-case or lower-case characters, except for the following 
characters:
    “  /  \  [  ]  :  ;  |  =  ,  +  *  ?  <  >

Full Name Enter the account user�s complete (full) name.  Entry in this field is optional.

Description Enter a description of the user or user account.  Entry in this field is optional.

Password Enter the password that the user must use to log on.  The password can contain up to 14 
characters.

Confirm Password Re-enter the password exactly as it was entered into the �Password� field.



Chapter 3  Routine OSMF System Administration

OSMF User Administration

3-6 55451A OSMF Software System Manual

097-55451-04

Issue 1

5 Click OK in the Add New User dialog box.

6 Perform one of the following actions:

� Make other changes as necessary in the User Manager dialog box.  The user just created will 
remain uncommitted to the database.

� To commit all modifications (including the user just created) to the database, click the 
Update Now button, then Yes in the confirmation box that follows.

� To cancel all uncommitted modifications (including the user just created), click the Undo All 
button (note that there is no way to cancel just the user addition).

� To commit the modifications and close the dialog box, click OK, then Yes in the confirma-
tion box that follows.

� To cancel all uncommitted modifications and close the dialog box, click Cancel.

3.2.1.2 To Modify a System User

NOTE The OSMF database must be running in order to perform the following task.  If the database is 
not currently running, choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ 
Database Services - Start to start it.

1 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ User Manager to 
call up the User Manager dialog box.

When the dialog box first appears, the message �Loading user... Please wait� 
appears in the user list area.  Eventually, the list of users appears in the user list area.

Groups Select the group that the user will belong to.  The group selected will determine the 
privileges that the user has when using the system.
� User - Users in this user group can view the network map as well as view the 

synchronization management information in the Alarm Viewer, Event 
History Log, Performance Monitor, Inventory, and configuration dialog 
boxes.  Users in this group can also create and print event and performance 
reports.

� Administrator - Users in this user group have all of the capabilities of the 
�User� group, and can additionally modify the inventory database and 
current configuration of SSUs.

� Security - Users in this user group have all of the capabilities of the �User� 
and �Administrator� groups, and can modify the network topology, manage 
default SSU configurations and manage or unmanage SSUs, view the 
transaction log1 and produce transaction log reports1, download firmware 
upgrades to SSUs1, set the date and time on SSUs1, create users on SSUs1, 
and configure management domains for users1.

NOTE Only one user can exist in the Security user group.  This user, the 
�svroot� user, is created when the OSMF software is installed.  The 
�svroot� logon name cannot be changed.

1 These features are available only if the Deluxe Edition of the OSMF software is enabled.

Field Description
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2 Select the user that you wish to modify in the user list that appears in the User Manager dialog 
box.

NOTE The �Account option� selection does not apply for user modifications.

3 Click the Modify... button to call up the Edit User dialog box.  The Edit User dialog box appears 
as follows:

4 Modify the user account information as is appropriate in the Edit User dialog box:

Field Description

Full Name Enter or modify the account user�s complete (full) name.  Entry in this field is optional.

Description Enter or modify the description of the user or user account.  Entry in this field is 
optional.

Password Double click to select the existing password (shown as a string of asterisks), then enter 
the new password.  The password can contain up to 14 characters.

Confirm Password Double click to select, then re-enter the new password exactly as it was entered into the 
�Password� field.
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5 Click OK in the Edit User dialog box.

6 Perform one of the following actions:

� Make other changes as necessary in the User Manager dialog box.  The user modifications 
just made will remain uncommitted to the database.

� To commit all modifications (including the modifications just made) to the database, click 
the Update Now button, then Yes in the confirmation box that follows.

� To cancel the user modifications just made, select the user in the user list, then click the 
Undo button.

� To cancel all uncommitted modifications (including the modifications just made), click the 
Undo All button.

� To commit the modifications and close the dialog box, click OK, then Yes in the confirma-
tion box that follows.

� To cancel all uncommitted modifications and close the dialog box, click Cancel.

3.2.1.3 To Delete a System User

NOTE The OSMF database must be running in order to perform the following task.  If the database is 
not currently running, choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ 
Database Services - Start to start it.

Groups Select the group that the user will belong to.  The group selected will determine the 
privileges that the user has when using the system.
� User - Users in this user group can view the network map as well as view the 

synchronization management information in the Alarm Viewer, Event 
History Log, Performance Monitor, Inventory, and configuration dialog 
boxes.  Users in this group can also create and print event and performance 
reports.

� Administrator - Users in this user group have all of the capabilities of the 
�User� group, and can additionally modify the inventory database and 
current configuration of SSUs.

� Security - Users in this user group have all of the capabilities of the �User� 
and �Administrator� groups, and can modify the network topology, manage 
default SSU configurations and manage or unmanage SSUs, view the 
transaction log1 and produce transaction log reports1, download firmware 
upgrades to SSUs1, set the date and time on SSUs1, create users on SSUs1, 
and configure management domains for users1.

NOTE Only one user can exist in the Security user group.  This user, the 
�svroot� user, is created when the OSMF software is installed.  The 
�svroot� logon name cannot be changed.

1 These features are available only if the Deluxe Edition of the OSMF software is enabled.

Field Description
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1 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ User Manager to 
call up the User Manager dialog box.

When the dialog box first appears, the message �Loading user... Please wait� 
appears in the user list area.  Eventually, the list of users appears in the user list area.

2 Select the user that you wish to delete in the user list that appears in the User Manager dialog 
box.

3 Choose the appropriate account option.

Select the �Make changes to both NT and OSMF-DB user accounts� radio button to delete the 
user from both Windows NT and the database, or the �Make changes to OSMF-DB user accounts 
only� radio button to delete the user only from the database.

4 Click the Delete button to delete the system user.

5 Perform one of the following actions:

� Make other changes as necessary in the User Manager dialog box.  The user deletion just 
made will remain uncommitted to the database.

� To commit all modifications (including the user deletion just made) to the database, click the 
Update Now button, then Yes in the confirmation box that follows.

� To cancel the user deletion just made, select the user in the user list, then click the Undo but-
ton.

� To cancel all uncommitted modifications (including the user deletion just made), click the 
Undo All button.

� To commit the modifications and close the dialog box, click OK, then Yes in the confirma-
tion box that follows.

� To cancel all uncommitted modifications and close the dialog box, click Cancel.
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3.3 Monitoring System Status
3.3.1 The �System Monitor� dialog box displays the status of various system parameters.  
The following figure and accompanying descriptions explain the �System Monitor� dialog box: 

This area shows the user that is currently logged on and the logon domain 
name.
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This area shows the state of the HP OpenView and Oracle services as of 
when the display area was last updated (as indicated by �Last Updated,� 
which appears below the display area).  If a given service is running, 
RUNNING will appear in the �State� column.  If it has been shut down, 
STOPPED will appear in the �State� column.

NOTE Other transient-type state messages might also be displayed 
(for example STOP_PENDING while a service is shutting 
down).

This area shows the state of the various OSMF daemons as of when the 
display area was last updated (as indicated by �Last Updated,� which 
appears below the display area).  If a given daemon is running, RUNNING 
will appear in the �State� column.  If a daemon has been shut down or is 
otherwise not running, NOT_RUNNING will appear in the �State� column.

NOTE If the HP OpenView Process Manager is not running, and all 
daemons are not running, this area will be blank.

The information under �Disk Free Space� shows the total disk space, as well 
as the amount of disk space used and free, for each drive/file system.  The 
Capacity column shows the percentage of space currently used in each 
drive/file system.

NOTE If free disk space decreases below 50M for any drive/file 
system, a disk space WARNING message will appear in place 
of the �Last Updated� message that normally appears below 
the display area.

The information under �Memory (KB)� shows various system RAM 
statistics.  The �Total Phys� field shows the total number of kilobytes of 
physical memory installed.  The �Avail. Phys� field shows the number of 
kilobytes of physical memory that are available.  The �Allocated� field 
shows the number of kilobytes of memory currently paged to disk.  The 
�Total Limit� field shows the maximum amount of memory that had been 
paged since bootup.
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3.3.1.1 To View the System Monitor
� Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ System 

Monitor.
The System Monitor shows a variety of system parameters, which are updated at a rate 
determined by the radio button selected under �Update Speed.�  The update speed can be 
changed by selecting another radio button, or automatic updating can be paused by selecting 
the �Paused� radio button.  The System Monitor can be updated at any time by clicking the 
Refresh button.

The information in the System Monitor is updated automatically at a rate 
determined by the radio button selected under �Update Speed.�  The display 
is updated approximately every five seconds when �Fast� is selected, 
approximately every twelve seconds when �Normal� is selected, and 
approximately every 80 seconds when �Slow� is selected.  If �Paused� is 
selected, the System Monitor will not be updated automatically.

The System Monitor can be updated at any time by clicking the Refresh 
button.  The last time each display area was refreshed is shown in the �Last 
Updated� message that appears below the display area.

Clicking the View Status Log... button opens a copy of the System Monitor 
log.  The System Monitor log is a running log of each event message that has 
been written to the System Monitor, along with the date and time when each 
was posted.  It is displayed using the Windows NT �Notepad.�  Logging 
starts when the System Monitor is opened, and ends when the System 
Monitor is closed, as evidenced by the �date/time started� and 
�date/time ended� entries in the log. Each time the System Monitor is 
closed and reopened, the log is flushed and restarted.

NOTE The System Monitor log is stored in the �Temp� folder as file 
�svsysmon.log.�

Clicking the Print Status Log... button calls up the System Monitor log and 
immediately prints it to the system default printer.

Clicking the NT System Tools... button invokes the Windows NT 
Troubleshooting Tools dialog box, from which you can select any of four 
troubleshooting programs that can be used to troubleshoot problems with the 
system.  The tools are standard Windows NT applications, so help on using 
them can be found by accessing the help systems that are available within the 
applications.
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� To close the System Monitor, click the Exit button.

3.3.1.2 To View or Print the System Monitor log
The System Monitor log is a running log of each event message that has been written to the 
System Monitor.  Logging starts when the System Monitor is opened, and ends when the System 
Monitor is closed.

� With the System Monitor opened, click the View Status Log... button.

When the View Status Log... button is clicked, the Windows NT �Notepad� program starts, 
and a copy of the System Monitor log is displayed within it.  The System Monitor log lists 
each event message that has been written to the System Monitor, along with the date and 
time when each was posted.  The messages are listed in chronological order.  The following 
shows an example System Monitor log:

The data in the log can be cut, pasted, or otherwise manipulated as the �Notepad� program is 
a standard word processing application.  Note that once �Notepad� opens, the log is not 
automatically updated in the �Notepad� window, although the log file (/temp/svsysmon.log) 
does continue to get updated.

It is important to note that once the System Monitor is closed, logging stops, and when the 
System Monitor is reopened, the /temp/svsysmon.log file is purged before logging restarts.  
If you wish to save a copy of the current instance of the log, you must save it to another file 
name or folder before reopening the System Monitor.

##### OSMF: System Monitor Log ######
date/time started: Wed Dec  2 08:19:29 PST 1998

Wed Dec  2 08:22:05 PST 1998 - ERROR: Unable to retrieve OSMF daemon status.
Wed Dec  2 08:22:15 PST 1998 - Service: OpenView Process Manager   State: STOPPED
Wed Dec  2 08:22:15 PST 1998 - ERROR: Unable to retrieve OSMF daemon status.
Wed Dec  2 08:22:26 PST 1998 - Service: OpenView Process Manager   State: STOPPED
Wed Dec  2 08:22:27 PST 1998 - ERROR: Unable to retrieve OSMF daemon status.
Wed Dec  2 08:22:38 PST 1998 - Service: OpenView Process Manager   State: STOPPED
Wed Dec  2 08:22:39 PST 1998 - ERROR: Unable to retrieve OSMF daemon status.
Wed Dec  2 08:22:50 PST 1998 - Service: OpenView Process Manager   State: STOPPED
Wed Dec  2 08:22:51 PST 1998 - ERROR: Unable to retrieve OSMF daemon status.
Wed Dec  2 08:23:02 PST 1998 - Service: OpenView Process Manager   State: STOPPED
Wed Dec  2 08:23:02 PST 1998 - ERROR: Unable to retrieve OSMF daemon status.
Wed Dec  2 08:23:13 PST 1998 - Service: OpenView Process Manager   State: STOPPED
Wed Dec  2 08:23:14 PST 1998 - ERROR: Unable to retrieve OSMF daemon status.
Wed Dec  2 08:23:25 PST 1998 - Service: OpenView Process Manager   State: STOPPED
Wed Dec  2 08:23:25 PST 1998 - ERROR: Unable to retrieve OSMF daemon status.
Wed Dec  2 08:23:36 PST 1998 - Service: OpenView Process Manager   State: STOPPED
Wed Dec  2 08:23:37 PST 1998 - Service: OracleTNSListener80   State: STOPPED
Wed Dec  2 08:23:37 PST 1998 - ERROR: Unable to retrieve OSMF daemon status.
Wed Dec  2 08:24:01 PST 1998 - Service: OpenView Process Manager   State: STOPPED
Wed Dec  2 08:24:01 PST 1998 - ERROR: Unable to retrieve OSMF daemon status.
Wed Dec  2 08:24:12 PST 1998 - Service: OpenView Process Manager   State: STOPPED
Wed Dec  2 08:24:13 PST 1998 - ERROR: Unable to retrieve OSMF daemon status.
date/time ended: Wed Dec  2 08:25:10 PST 1998
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� If the System Monitor log is already opened, you can print it to a printer using the menu 
selections available within the �Notepad� window.  To otherwise print the System Monitor 
log to the default system printer, click the Print Status Log... button.

3.3.1.3 To Start One of the Windows NT Troubleshooting Tools
Any of four troubleshooting programs can be started from the System Monitor.  These programs 
can be useful when troubleshooting system problems, or planning for future system needs.

� With the System Monitor opened, click the NT System Tools... button.

When the NT System Tools... button is clicked, the Windows NT Troubleshooting Tools 
dialog box opens.  This dialog box contains four buttons, which can be clicked to start the 
following four Windows NT Troubleshooting applications:

The troubleshooting tools are standard Windows NT applications, so help on using them can 
be found by accessing the help systems that are available within the applications.

Button Description

Event Viewer... Invokes the Windows NT Event Viewer, in which you can view and manage 
System, Security, and Application event logs.

Performance Monitor... Invokes the Windows NT Performance Monitor, which is a graphical tool for 
monitoring the computer�s efficiency.  It allows you to view and monitor the 
behavior of various objects such as the processor, memory, threads, 
processes, etc.

Task Manager... Invokes the Windows NT Task Manager, which allows you to monitor 
applications and processes that are running on the computer, various system 
parameters, and display a dynamic overview of the computer�s CPU and 
memory usage.  Applications and processes can also be started and stopped 
using the Task Manager.

Windows NT Diagnostics Invokes the Windows NT Diagnostics dialog, which allows you to view 
hardware information in the Registry, such as currently loaded device driver 
and IRQ values.
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3.4 To Archive Performance History Data, Events, and Transactions
3.4.1 An OSMF software process copies events and performance history data that is older than 
14 days to special archive tables in the database.  This software process also copies transactions 
that are older than 30 days to the archive tables.  These archive tables have pre-allocated space 
for 200,000 performance entries, 100,000 event entries, and 15,000 transaction entries.  Software 
functionality problems might occur if the tables fill up. The archive tables, therefore, should 
periodically be cleaned.  The procedure in this section can be used to archive the data contained 
in the archive tables, and consequently clean them out.

3.4.2 In the procedure that follows, an archive script is run.  This script does the following:

� Copies performance history data, events, and transactions from the archive tables to a report 
file.

� Names the report file to reflect the range of the data it contains.
� Deletes the information from the archive tables.
� Removes any entries that have accumulated in the event error log (which contains any events 

that could not be processed due to an error).

3.4.3 To complete the archive process, the system administrator should copy the report file to an 
offline storage device, such as a local tape drive, and then delete the report file from the system.

NOTES Your tape drive should be cleaned on a regular basis.  Please refer to the tape drive manual for 
cleaning frequency and instructions.  If a proper cleaning schedule is not maintained, data 
integrity might be compromised.

The following procedure must be performed as part of regularly-scheduled system maintenance 
to ensure that the system continues to operate efficiently.  It is recommended that the procedure 
be performed at least once every week.

1 If not logged on as user svroot, perform the following steps:

a. Choose Start ⇒ Shut Down...
b. In the �Shut Down Windows� box that appears, select the �Close all programs and 

log on as a different user� radio button, then click the Yes button.

c. When the box containing the message �Press Ctrl + Alt + Delete to log on� 
appears, simultaneously press the Ctrl, Alt, and Del keys.

d. Log in as the svroot user, and enter the svroot password.

2 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Database System 
Archive.

When Database System Archive is selected, a �SVARCHIVE� window opens, which 
displays the following messages as the archive process proceeds:
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Suspending archive daemons...
Retrieving the minimum date associated with the archived files...
Retrieving the maximum date associated with the archived files...
Copying the archived events to file...
Truncating the archive table and event error log table...
Resuming the database background processes...

When the archive process completes, a message box containing the message �Archive data 
has been placed in 
drive:/osmf/Oracle/admin/Sv30/arch/expolddate_mrdate.TXT� appears 
(where drive is the OSMF install drive, such as �c:�).

NOTE If there is no information to archive, the message �No events found for archiving, 
Exiting...� will be displayed.

3 Click OK in the message box to close it and the �SVARCHIVE� window.

The archive process produces a report file in the drive:/osmf/Oracle/admin/Sv30/arch 
directory with the name �expolddate_mrdate.TXT� where olddate is the date of the 
oldest data in the file, and mrdate is the date of the most recent data in the file.  As an example, 
if the oldest data in the file was generated on March 15, 1997 and the most recent data in the file 
was generated on March 24,1997, the file name would be exp970315_970324.TXT.

The report file is a text file that can be viewed using any text editor.  Refer to the Example 
Archive Report File, below, for an example of a report file.

NOTE The report file should be copied to a local tape drive or other offline storage device, then it 
should be deleted from the /osmf/Oracle/admin/Sv30/arch directory.

Example Archive Report File

PERFORMANCE DATA
----------------
"15.1.1.1","0","FFOFF","192S","98-03-23 08:58:59",".000012" 
"15.1.1.1","0","TDEV","256S","98-03-23 08:58:59",".000012" 
"15.1.1.1","0","MRTIE","2H","98-03-23 08:58:59",".000012" 
"15.1.1.1","0","LMRTIE","2H","98-03-23 08:58:59",".000012" 
"15.1.1.1","0","FFOFF","768S","98-03-23 08:58:59",".000012" 
"15.1.1.1","0","TDEV","1024S","98-03-23 08:58:59",".000012" 
"15.1.1.1","0","MRTIE","8H","98-03-23 08:58:59",".000012" 
"15.1.1.1","0","LMRTIE","8H","98-03-23 08:58:59",".000012" 
"15.1.1.1","0","FFOFF","3072S","98-03-23 08:58:59",".000012" 
"15.1.1.1","1","TDEV","1S","98-03-23 08:58:59",".000023" 
"15.1.1.1","1","MRTIE","1S","98-03-23 08:58:59",".000023" 
"15.1.1.1","1","LMRTIE","1S","98-03-23 08:58:59",".000023" 
"15.1.1.1","1","FFOFF","3S","98-03-23 08:58:59",".000023" 
"15.1.1.1","1","TDEV","4S","98-03-23 08:58:59",".000023" 
"15.1.1.1","1","MRTIE","15M","98-03-23 08:58:59",".000023" 
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"15.1.1.1","1","LMRTIE","15M","98-03-23 08:58:59",".000023" 
"15.1.1.1","1","FFOFF","12S","98-03-23 08:58:59",".000023" 
"15.1.1.1","1","TDEV","16S","98-03-23 08:58:59",".000023" 
"15.1.1.1","1","MRTIE","30M","98-03-23 08:58:59",".000023" 
"15.1.1.1","1","LMRTIE","30M","98-03-23 08:58:59",".000023" 
**

   Fields are separated by commas
           Field 1: IP Address
           Field 2: Channel no. (0-8)
           Field 3: Performance type
           Field 4: time interval
           Field 5: time stamp
           Field 6: value

EVENTS/ALARMS DATA
------------------
"1","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:52","Output Card Not Present" 
"2","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:52","Output Card Not Present" 
"3","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:52","Output Card Not Present" 
"4","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:52","Output Card Not Present" 
"5","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:52","Output Card Not Present" 
"6","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:52","Output Card Not Present" 
"7","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:52","Output Card Not Present" 
"8","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:52","Output Card Not Present" 
"9","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:52","Output Card Not Present" 
"10","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:52","Output Card Not Present" 
"11","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:52","Output Card Not Present" 
"312","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:54","Output Card Not Present" 
"313","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:54","Output Card Not Present" 
"314","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:54","Output Card Not Present" 
"315","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:54","Output Card Not Present" 
"316","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:54","Output Card Not Present" 
"317","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:54","Output Card Not Present" 
"318","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:54","Output Card Not Present" 
"319","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:54","Output Card Not Present" 
"320","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:54","Output Card Not Present" 
"321","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:54","Output Card Not Present" 
"322","SSU-9","OUT4B","MINOR","Y","98-03-23 08:56:54","Output Card Not Present" 

**

   Fields are separated by commas
            Field 1: event number
            Field 2: selection name
            Field 3: aid
            Field 4: severity
            Field 5: sa
            Field 6: event time
            Field 7: event message

TRANSACTION LOG DATA
--------------------
"1","Add","SVROOT","98-09-28 12:09:23","S-221","SSU","","",""
"2","Add","SVROOT","98-09-28 12:09:23","S-222","SSU","","",""
"3","Remove","SVROOT","98-09-28 12:09:23","S-222","SSU","","",""
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"4","Add","SVROOT","98-09-28 12:09:23","S1$1->S2$0$D$8","SYNC-TRAIL","","",""
"5","Remove","SVROOT","98-09-28 12:09:23","S1$1->S2$0$D$8","SYNC-TRAIL",
   "","",""
"6","Edit","SVROOT","98-09-28 12:09:23","S-221","OUTA","MANAGED","Y","N"
"7","Edit","SVROOT","98-09-28 12:09:23","S-221","OUTA","HW_ALIGNED","Y","N"
"8","Edit","SVROOT","98-09-28 12:09:23","S-221","ITH","PIRANGE","4600","10000"
"9","Edit","SVROOT","98-09-28 12:09:23","S-221","IMC","LCLBAUD","2400","9600"
"10","Edit","SVROOT","98-09-28 12:09:23","S-221","S0-OUTA","SSMBIT","SA4",
   "SA7"
"11","Edit","SVROOT","98-09-28 12:09:23","S-221","S4-OUTE","SABITS","223",
   "150"
"12","Edit","SVROOT","98-09-28 12:09:23","S-221","S2-OUTC","HLDACT",
   "CONTINUE","AIS"
"13","Edit","SVROOT","98-09-28 12:09:23","S-221","S2-OUTC-1","SQUELCH","Y","N"
"14","Edit","SVROOT","98-09-28 12:09:23","S-221","S2-OUTC-16","SQUELCH","N",
   "Y"
"15","Edit","SVROOT","98-09-28 12:09:23","S-221","ITH-0","ENABLE","N","Y"
"16","Edit","SVROOT","98-09-28 12:09:23","S-221","ITH-1","FORMAT","E1","SQW"
"17","Edit","SVROOT","98-09-28 12:09:23","S-221","ITH-9","CURRSSM","128","210"
"18","Edit","SVROOT","98-09-28 12:09:23","S-221","ITH-1-SPRD-3S","THR",
   "12.9878","3.43874"
"19","Edit","SVROOT","98-09-28 12:09:23","S-221","ITH-8-LMRTIE-3071S","THR",
   "12.9878","3.43874"
"20","Edit","SVROOT","98-09-28 12:09:23","S-221","ITH-8-MRTIE-1S","PM","Y","N"
"21","Un-Ack","SVROOT","98-09-28 12:09:23","S-221","SSU","INPDISQ","",""
"22","Un-Ack","SVROOT","98-09-28 12:09:23","S-221","SSU","SE-CFGRM","",""
"23","Cut-Off","SVROOT","98-09-28 12:09:23","S-221","SSU","","",""
"24","Dw-F/w","SVROOT","98-09-28 12:09:23","S-221","SSU","3724 firmware","",""
"25","Dw-Cfg","SVROOT","98-09-28 12:09:23","S-221","SSU","Standard Config",
   "",""

**

   Fields are separated by commas
           Field 1: Transaction serial number
           Field 2: Transaction type
           Field 3: User ID
           Field 4: Date/time stamp
           Field 5: Object name
           Field 6: Object class (AID)
           Field 7: Attribute name
           Field 8: Old value
           Field 9: New value

3.4.3.1 Backup and Recovery
The purpose of the archive process explained above is to maintain the database within limits 
under normal operating conditions.  Backup and recovery utilities are provided to backup the 
database so that it can be recovered in the event of a failure.  Refer to the System Backup and 
Recovery chapter in this manual for more information.
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3.5 To Synchronize the Date and Time of SSUs with the OSMF System
3.5.1 The OSMF software contains a utility that sources the current date and time as it occurs on 
the OSMF system to every SSU indicated as �managed� in the OSMF database.   In succession 
for each managed SSU, the current date and time is fetched from the system and then 
downloaded to the SSU.  This allows for very accurate time synchronization between all SSUs in 
the network, notwithstanding slight inaccuracies resulting from network delays, which are 
typically very small (typically within milliseconds).

1 If not logged on as user svroot, perform the following steps:

a. Choose Start ⇒ Shut Down...
b. In the �Shut Down Windows� box that appears, select the �Close all programs and 

log on as a different user� radio button, then click the Yes button.

c. When the box containing the message �Press Ctrl + Alt + Delete to log on� 
appears, simultaneously press the Ctrl, Alt, and Del keys.

d. Log in as the svroot user, and enter the svroot password.

2 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Set SSU Date.

When Set SSU Date is selected, the date and time of the SSUs is synchronized with the date and 
time of the OSMF system.  As the utility runs, a �Set SSU Date� terminal window temporarily 
opens, then closes when the utility finishes running.
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4.1 In this Chapter
4.1.1 The procedures in this chapter can be used to perform regularly scheduled backups of the 
OSMF system.  If a disaster occurs, such as a database crash that leads to data corruption, the 
recovery information in this chapter can be used to recover from the failure.

The following sections are included in this chapter:

� System Backup
� Backup Procedures
� System Recovery

NOTES Your tape drive should be cleaned on a regular basis.  Please refer to the tape drive manual for 
cleaning frequency and instructions.  If a proper cleaning schedule is not maintained, data 
integrity might be compromised.
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4.2 System Backup
4.2.1 It is important to maintain a recent backup of the OSMF system. In the event of hardware 
failure, operator error, or other disaster, the backup will provide the most direct path to 
restoration of the system and user data.

4.2.1.1 Backup Categories
The OSMF software system-level backup can be divided into four broad backup categories:

� NT Core System Backup

The core system backup is an offline image backup of the entire system boot disk, which 
provides a complete path to recovery from the time the backup was performed.  Third-party 
NT system backup products are available to assist the System Administrator in preparing a 
core system backup.  It is recommended that an NT Core Backup media should always be 
prepared.

� System Backup

This is an online backup of all files except for the OSMF database. (in other words, 
excluding the �/OSMF/ORACLE/data� directory which contains the OSMF database files).  
This will backup the entire system, applications, and user files needed to recover from a 
system that is already running. This backup does not provide the low level formatting of the 
disk drive as the NT core system backup does.

There are many methods that can be used to produce a System Backup.  One method of 
performing the online System Backup is with the Windows NT Backup tool, which is a 
standard part of the Windows NT operating system/environment. Files can be included or 
excluded when defining the scope of the backup or recovery.

Full and Incremental backups may be performed using the backup tool. Full backup will 
backup the entire system. Incremental backups will backup any file that has changed since 
the last Full backup.

It is best if all applications as well as HP OpenView, Oracle, and the OSMF software 
processes are not running for this backup. HP OpenView, Oracle, and the OSMF software 
have processes which will have file locks. This should not inhibit the backup from 
completing, however, for best results the HP OpenView, Oracle, and OSMF applications 
should be shut down. It is still possible to depend on the NT Core System Backup for the 
system recovery at this level, if the applications cannot be interrupted. Even though the 
OSMF software�s associated applications can be running during the backup, they should not 
be running during a system recovery.

� OSMF Database Hot Backup

The OSMF system can be set up to automatically perform regularly-scheduled backups of 
database-related files using the Database Backup Scheduler.  These are hot backups, 
meaning they are run while the OSMF software and related processes are running.
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� OSMF Database Backup Plus HP OpenView

This backup is similar to the database backup, but it cannot be set up to run automatically.  It 
backs up the database-related files, but also backs up HP OpenView data, such as map 
background graphics.  The OSMF software and related processes must be shut down while 
this backup is run.  This backup can be run less frequently than the OSMF Database Hot 
Backup.

4.2.1.2 Special Considerations
Special considerations should be observed when backing up an online database. The database 
will have active files and locks that may prevent some backup programs from accessing certain 
files. It is strongly recommended that the OSMF database be excluded from any System Backup. 
The backup of the OSMF database files should be performed using the OSMF Database Hot 
Backup procedure, which takes online backups (�hot backups�) and is designed specifically for 
the OSMF database.

4.2.1.3 Backup Requirements
Based on different needs and configurations, backup requirements and methods will vary. As 
part of the OSMF software management solution, the following backup scenario is 
recommended:

� NT Core System Backup - Off-line core system backup should be done every 3 months, or 
whenever hardware additions or software changes are made.  This backup will ensure a 
properly bootable system in the event of a disk replacement.  This backup must be scheduled 
and users notified since the system likely will be offline.

� System Backup - Complete backup of system (excluding the OSMF database) should be 
done once every 1 week using a system backup tool, such as Windows NT Backup.

NOTES To exclude the OSMF database from the system backup, exclude the �/OSMF/ORACLE/data� 
directory.

It is recommended that you shutdown the OSMF software, HP OpenView, and Oracle processes 
during a System Backup. This is not required, however, a greater level of data integrity is 
possible while the applications are not running.

� OSMF Database Hot Backup - The OSMF database hot backup should be done at least 
once a day.  It can be set up to run automatically on a daily basis.

� OSMF Database Backup Plus HP OpenView - The OSMF database backup plus HP 
OpenView can be run less frequently than the OSMF Database Hot Backup.

The NT Core System Backup should be considered very important and be kept current.  Based 
on needs, the System Backup may be performed more or less frequently.  If no changes are made 
to the system or user files between backups, the System Backup cycle time may be increased.  If 
frequent changes are made to user files, then incremental backups may also be scheduled in the 
System Backups.  The OSMF database should be backed up at least once a day, and the Database 
Backup Scheduler should be used to schedule backups to run automatically.
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4.3  Backup Procedures
4.3.1 The following backup procedures are included as part of the OSMF software management 
solution.

4.3.1.1 NT Core System Backup
Third-party NT system backup products are available to assist the System Administrator in 
preparing a core system backup.  Consult the documentation supplied with the NT system 
backup product for information on performing a core system backup.

4.3.1.2 System Backup
Third-party NT backup products are available to assist the System Administrator in preparing a 
System Backup.  One such tool, the Windows NT Backup, is a standard part of the Windows NT 
operating system/environment, and as such is typically installed along with the operating system.

When preparing a System Backup, be aware that certain files might have read locks which will 
prevent them from being backed up.  Your file system might have several partitions which you 
might want to back up.  You also might want to exclude certain files from the backup, if it is not 
important that they be backed up.

In the following example, all files on the �c:� drive except for the OSMF database are backed up 
using the Windows NT Backup (in other words, the �/OSMF/ORACLE/data� directory, which 
contains the OSMF database files, is excluded).

1 If not logged on as user svroot, perform the following steps:

a. Choose Start ⇒ Shut Down...
b. In the �Shut Down Windows� box that appears, select the �Close all programs and 

log on as a different user� radio button, then click the Yes button.

c. When the box containing the message �Press Ctrl + Alt + Delete to log on� 
appears, simultaneously press the Ctrl, Alt, and Del keys.

d. Log in as the svroot user, and enter the svroot password.

2 Choose Start ⇒ Programs ⇒ OSMF ⇒ OSMF Manager ⇒ OSMF Services - Stop to 
shut down the software and related processes.

When the OSMF Services shutdown procedure commences, an �OSMF Services - Stop� dialog 
box appears.  Note that the Restart button in the dialog box is de-emphasized (�grayed out�) at 
that point.  As each process is shut down, it appears in the dialog box. After all processes have 
been shut down, the Restart button becomes active (emphasized).

3 After the HP OpenView and OSMF software processes have been shut down, click the Close 
button in the �OSMF Services - Stop� dialog box to close it.
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4 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Database Services 
- Stop to stop the Oracle database.

As the database is being shut down, a �svdbshut� terminal window appears which displays some 
status messages.  After the database shutdown process is complete, the �svdbshut� terminal 
window closes.

5 Insert a tape into the local tape drive.

6 Choose Start ⇒ Programs ⇒ Administrative Tools (Common) ⇒ Backup

When Backup is chosen, the Backup dialog box appears.  This dialog box contains two sub-
windows: one labeled �Drives� and one labeled �Tapes.�

7 If the Drives window is not maximized, maximize it, then select the check-box that is adjacent to 
the icon of the drive or drives that contain the database files to be backed up, as in the following 
for the �c:� drive:

This action selects all files on the disk for backup.

8 Double-click on the drive symbol to expand it, then drill down to the �data� folder by first 
double-clicking the OSMF folder, then the ORACLE folder.

9 Click the check-box that is adjacent to the �data� folder so that it is deselected, as shown in the 
following example:

10 Click the Backup button to invoke the Backup Information dialog box.

11 Click OK in the Backup Information dialog box.

A Backup Status dialog box appears and the backup progresses.
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12 When the message �The operation was successfully completed� appears in the 
Backup Status dialog box, click OK, then close the Backup dialog box.

13 Remove the backup tape from the tape drive and store it in a secure place.

4.3.1.3 OSMF Database Hot Backup

NOTE The following procedure can be used at any time to perform a hot backup manually.  It is 
strongly suggested that database hot backups be set up to run automatically on a daily basis using 
the Database Backup Scheduler.  The procedure entitled Scheduling Database Backups at the 
end of this section explains how to schedule backups to run automatically.

The following procedure backs up all of the OSMF database files.  It is a hot backup, that is to 
say, it can be run while the OSMF software and related processes are running.  This procedure 
should be run at least once a day.

1 If not logged on as user svroot, perform the following steps:

a. Choose Start ⇒ Shut Down...
b. In the �Shut Down Windows� box that appears, select the �Close all programs and 

log on as a different user� radio button, then click the Yes button.

c. When the box containing the message �Press Ctrl + Alt + Delete to log on� 
appears, simultaneously press the Ctrl, Alt, and Del keys.

d. Log in as the svroot user, and enter the svroot password.

2 Insert a tape into the local tape drive.

3 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Database System 
Backup.

When Database System Backup is chosen, the OSMF Database Backup dialog box appears:

The database backup process compresses the database-related files and places the compressed 
files into the /Temp/backup folder.  As the backup process progresses, messages similar to the 
following appear in the OSMF Database Backup dialog box:
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User and group verified
Database backup started on Thu Apr 8 13:09:46 PDT 1999
.......................................
List of data files compressed as part of the hot backup :
.....................................................
Compressing d:\OSMF\oracle\data\sv30\APPL01.DBF, size:272633856
Compressing d:\OSMF\oracle\data\sv30\APPL02.DBF, size:272633856
Compressing d:\OSMF\oracle\data\sv30\IND01.DBF, size:62918656
Compressing d:\OSMF\oracle\data\sv30\IND02.DBF, size:62918656
Compressing d:\OSMF\oracle\data\sv30\SYSTEM01.DBF, size:52432896
Compressing d:\OSMF\oracle\data\sv30\TEMP01.DBF, size:41947136
Compressing d:\OSMF\oracle\data\sv30\RBS01.DBF, size:31461376
Compressing d:\OSMF\oracle\data\sv30\TOOLS01.DBF, size:10489856
List of log files compressed before backup along with their size
...................................................
Compressing SV30_01A.LOG,size:2097664
Compressing SV30_01B.LOG,size:2097664
Compressing SV30_02A.LOG,size:2097664
Compressing SV30_02B.LOG,size:2097664
Compressing SV30_03A.LOG,size:2097664
Compressing SV30_03B.LOG,size:2097664
List of archive redo log files compressed before backup along with 
their size
................................................................
Compressing SV30T0001S0000000052.ARC,size:1652736
Compressing SV30T0001S0000000053.ARC,size:2097664
List of control files compressed before backup along with their size
.......................................................
Compressing SV30_01.CTL,size:643072
Compressing SV30_02.CTL,size:643072
Compressing SV30_03.CTL,size:643072
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After all files are compressed and stored in the /Temp/backup directory, the portion of the backup 
process that copies the files to tape automatically starts, and the following dialog box appears:

The following three items indicate that the OSMF database backup has completed successfully 
with no errors:

� The Backup Status and Verify Status dialog boxes close.
� The message �DATABASE BACKUP COMPLETED SUCCESSFULLY� appears in the 

OSMF Database Backup dialog box.
� The progress gauge in the OSMF Database Backup dialog box reads 100% Completed.

4 Click OK in the OSMF Database Backup dialog box to close it.

5 Remove the backup tape from the tape drive and store it in a secure place.

4.3.1.4 OSMF Database Backup Plus HP OpenView
The following procedure backs up all of the OSMF database files and also HP OpenView data, 
such as map background graphics.  Recovery of a backup performed using this procedure will 
yield a more accurate rendition of the HP OpenView maps, if much customization had been 
performed.

The disadvantage of backing up the HP OpenView data along with the database files is that the 
OSMF software and related processes must be shut down while the backup is run.  The OSMF 
Database Hot Backup (explained above) should be run on a daily basis.  The following 
procedure, however, can be run less frequently.

1 If not logged on as user svroot, perform the following steps:

a. Choose Start ⇒ Shut Down...
b. In the �Shut Down Windows� box that appears, select the �Close all programs and 

log on as a different user� radio button, then click the Yes button.

c. When the box containing the message �Press Ctrl + Alt + Delete to log on� 
appears, simultaneously press the Ctrl, Alt, and Del keys.
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d. Log in as the svroot user, and enter the svroot password.

2 Choose Start ⇒ Programs ⇒ OSMF ⇒ OSMF Manager ⇒ OSMF Services - Stop to 
shut down the software and related processes.

When the OSMF Services shutdown procedure commences, an �OSMF Services - Stop� dialog 
box appears.  Note that the Restart button in the dialog box is de-emphasized (�grayed out�) at 
that point.  As each process is shut down, it appears in the dialog box. After all processes have 
been shut down, the Restart button becomes active.

3 After the OSMF software and related processes shut down, insert a tape into the local tape drive.

4 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Database System 
Backup & OpenView.

After the OSMF Database Backup dialog box opens, the indications given are similar to those 
given for the OSMF database hot backup, as explained after step 3 of the above procedure.

4.3.1.5 Scheduling Database Backups
Database hot backups should be set up by the system administrator to run automatically on a 
regular basis using the Database Backup Scheduler.  The database backup should be scheduled 
during a time when system resource use will normally be low.  The following procedure explains 
how to schedule database backups to run nightly at 12:30 am:

1 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Database Backup 
Scheduler.

When Database Backup Scheduler is chosen, the OSMF:Database Backup Scheduler dialog 
box appears:
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2 Click the Add button to invoke the Add Schedule dialog box:

3 In the �Date� area of the dialog box, select the �Every� radio button, then select �Day� in the 
scroll box.

4 Enter 12:30 into the time fields, and de-select the �PM� check-box if it is selected.

5 Click OK in the Add Schedule dialog box.

6 Click Done in the OSMF:Database Backup Scheduler dialog box to close it.
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4.4 System Recovery
4.4.1 In the event of data loss, data can be recovered from the backup archive.  Different levels of 
recovery may exist depending on the amount of data loss.

4.4.1.1 Complete System Recovery
This level of recovery includes if the boot disk is replaced.  It is broken into three main steps, or 
sub-procedures.

NOTE There may be different variations of the following steps depending on how much data was lost. If 
the system is able to run the recovery process, Step 1 is not required. If only the database 
recovery is required, Step 1 and Step 2 are not needed.

Step 1 - This involves recovery of the NT Core System.

Third-party NT system backup products are available to assist the System Administrator in 
preparing the core system backup.  The core system backup thus produced can now be used to 
recover the system using the process supplied with the NT system backup product.

In any case, if the system disk was damaged, it will need to be replaced before core system 
recovery can take place.  Replace the bad disk and assure the new disk�s address is set the same 
as the old disk.  Refer to the manufacturer�s hard drive documentation for setting the address.

After the core system is recovered, the data is restored onto your new disk drive.  You can then 
exit the program and cycle the system�s power off and then on.  When the power is cycled, the 
system will boot from the new installed disk.

If there were no major changes to the system since the last core system backup was performed, 
then the following procedure (Step 2) can be bypassed.  If any application or user files need to be 
recovered, perform Step 2 to recover them.

NOTE All application and user files are included on the NT Core Backup.  You might not need to 
restore any other system files once Step 1 is complete.

Step 2 - This involves restoring any application or user files to the system from the System 
Backup tape.

The following procedure gives an example of how to do this using the Windows NT Backup tool.  
Note that this process is only needed if the data restored in Step 1 is not current.  Step 1 produces 
a fully functional system.  Step 2 allows restoration of changes made since Step 1.

In the following example procedure, assume a portion of the /Openview/bin directory was 
removed or lost, in which case just that directory needs to be recovered.
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1 If not logged on as user svroot, perform the following steps:

a. Choose Start ⇒ Shut Down...
b. In the �Shut Down Windows� box that appears, select the �Close all programs and 

log on as a different user� radio button, then click the Yes button.

c. When the box containing the message �Press Ctrl + Alt + Delete to log on� 
appears, simultaneously press the Ctrl, Alt, and Del keys.

d. Log in as the svroot user, and enter the svroot password.

2 Insert the tape containing the files to be recovered into the local tape drive.

3 Choose Start ⇒ Programs ⇒ Administrative Tools (Common) ⇒ Backup

When Backup is chosen, the Backup dialog box appears.  This dialog box contains two sub-
windows: one labeled �Drives� and one labeled �Tapes.�

4 If the Tapes window is not maximized, maximize it, then de-select the check-box that is adjacent 
to the tape icon in the left side of the Tapes window if it is selected (see the following example):

5  In the right pane of the Tapes window, drill down to the �bin� folder by double-clicking the root 
folder, then the �OpenView� folder.

NOTE If the Tapes window does not contain two panes, select �Tree and Directory� from the �View� 
menu to set the view to show the tree in the left pane, and the directory structure in the right pane.

6 Click the check-box that is adjacent to the �bin� folder so that it is selected, as shown in the 
following example:

7 Click the Restore button to invoke the Restore Information dialog box.

8 Click OK in the Restore Information dialog box.

A Restore Status dialog box appears and the restoration progresses.
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NOTE If a �Confirm File Replace� question box appears, click Yes to All.

9 When the message �The operation was successfully completed� appears in the 
Restore Status dialog box, click OK, then close the Backup dialog box.

Step 3 - This involves restoring the OSMF database backup and HP OpenView files from 
tape produced using the database backup procedures.

In this procedure, the OSMF database is brought to the level of the backup from which the 
recovery is being done.

If a backup tape was prepared using the OSMF Database Backup Plus OpenView procedure, and 
it is more recent than the tape produced using the hot database backup procedure, you will want 
to restore from it.  If you have backup tapes that were produced using both the OSMF Database 
Backup Plus OpenView procedure and the OSMF Database Hot Backup procedure, and the hot 
backup tape is more recent, you might want to recover first from the tape containing the HP 
OpenView data, then recover the most recent database from the hot backup tape.  The following 
procedure can be run twice to recover from both of these tapes.

1 If not logged on as user svroot, perform the following steps:

a. Choose Start ⇒ Shut Down...
b. In the �Shut Down Windows� box that appears, select the �Close all programs and 

log on as a different user� radio button, then click the Yes button.

c. When the box containing the message �Press Ctrl + Alt + Delete to log on� 
appears, simultaneously press the Ctrl, Alt, and Del keys.

d. Log in as the svroot user, and enter the svroot password.

2 Ensure that no OSMF, HP OpenView NNM, or Oracle processes are running.

If these processes are not running, the Status Monitor will indicate that �OpenView Process 
Manager� and �Oracle TNSListner80� are STOPPED.  If no OSMF, HP OpenView 
NNM, or Oracle processes are running, continue with the next step.  If any of these processes are 
running, perform the procedure entitled To Stop the OSMF Software and Database in the chapter 
entitled Starting and Stopping the OSMF Software before continuing with the next step.

3 Insert the tape containing the files to be recovered into the local tape drive.

If you need to recover the database as well as the HP OpenView data, recover the tape that 
contains the most recent data last.  If the tape that contains the HP OpenView data is the most 
recent backup, you only need to recover it.

4 Choose Start ⇒ Programs ⇒ Administrative Tools (Common) ⇒ Backup

When Backup is chosen, the Backup dialog box appears.  This dialog box contains two sub-
windows: one labeled �Drives� and one labeled �Tapes.�
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5 If the Tapes window is not maximized, maximize it, then select the check-box that is adjacent to 
the tape icon in the left side of the Tapes window, as in the following example:

6 Click the Restore button to invoke the Restore Information dialog box.

7 Click OK in the Restore Information dialog box.

A Restore Status dialog box appears.

NOTE If a �Confirm File Replace� question box appears, click Yes to All.

8 When the message �The operation was successfully completed� appears in the 
Restore Status dialog box, click OK, then close the Backup dialog box.

9 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Database System 
Recovery.

When Database System Recovery is selected, the Recover Database From Tape dialog box is 
invoked.  This dialog box provides a listing of all of the files to be recovered.  The last column 
shows if the respective file has been recovered.  At this point, this column (�Recovered�) should 
indicate �No� for all files, as in the following example:

10 Click the Start Recovery button in the Recover Database From Tape dialog box.

An �SVDBRECOVER - MESSAGE� box appears, which contains the question �Do you 
wish to proceed with the recovery process?�.

11 Click the Yes button to start the recovery process.
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A �Yes� indication will appear in the �Recovered� column of the Recover Database From Tape 
dialog box as each file is recovered.  When all files have been recovered and Oracle Recovery is 
complete, an �SVDBRECOVER - MESSAGE� box appears, which contains the message �OSMF 
database recovery completed successfully�.

12 Click OK in the �SVDBRECOVER - MESSAGE� box.
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5.1 Overview
5.1.1 The OSMF software is shipped on a Compact Disk (CD) that contains the current version 
of the both the standard edition and deluxe edition of the following software:

� OSMF Management Server Software - This software package should be installed on the 
system acting as the Management Server, that is, the system that contains the OSMF 
database.  There is typically one Management Server per installation.

� OSMF Management Client Software - This software package should be installed on each 
system acting as a Management Console.  There can be up to four Management Consoles per 
installation.

NOTE The chapter entitled Introduction and General Information explains the features provided in both 
the standard edition and deluxe edition of the software.

The procedures in this chapter explain how to install the software.  The installation procedure 
that you use depends on the current status of your OSMF system�s database, and whether the 
installation is on a Management Server, or Management Console:

� If you are installing the OSMF Management Server software on a system for the first time, or 
you are upgrading the OSMF software from version 2.0 to 3.0, use the procedure To Install 
the OSMF Management Server Software - Initial installations and Upgrades.

� If you are reinstalling the same version of OSMF Management Server software, and that 
system contains an existing OSMF database, use the procedure To Install the OSMF 
Management Sever Software - Reinstallations.

� If you are installing the OSMF Management Client software (either for the first time or as an 
upgrade), use the procedure To Install the OSMF Management Client Software.
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5.2 To Install the OSMF Management Server Software - Initial Installations 
and Upgrades
5.2.1 If you are installing the OSMF Management Server software on your system for the first 
time, or upgrading the OSMF software from version 2.0 to version 3.0, use the following 
procedure.

CAUTION If the following procedure is used to upgrade the OSMF Management Server software, or 
reinstall it, the entire OSMF database will be destroyed.  If you are upgrading the OSMF 
Management Server software, or reinstalling the same version of software, go to the procedure 
entitled To Install the OSMF Management Server Software - Software Upgrades.

NOTE Before beginning the OSMF Management Server software installation, certain system 
requirements must be met, and the HP OpenView software and Oracle software must be properly 
installed and configured on your system.

Refer to the System Requirements section in the chapter entitled Introduction and General 
Information in this manual for a listing of the current hardware and software system 
requirements for a Management Server.  Refer to the appropriate HP OpenView and Oracle 
documentation for information on how to install the HP OpenView and Oracle software.

5.2.1.1 Remove the Existing Version of OSMF Software (software upgrades only)
1 Log into the system as svroot (if necessary).

2 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ System Monitor to 
ensure that no OSMF, HP OpenView NNM, or Oracle processes are running.

If these processes are not running, the Status Monitor will indicate that �OpenView Process 
Manager� and �Oracle TNSListner80� are STOPPED.  If no OSMF, HP OpenView 
NNM, or Oracle processes are running, close the System Monitor, then continue with the next 
step.  If any of these processes are running, perform the procedure entitled To Stop the OSMF 
Software and Database in the chapter entitled Starting and Stopping the OSMF Software before 
continuing with the next step.

3 Close all OSMF application windows, and exit all Windows programs that are currently running 
on the system (although closing all Windows programs is not required, it is strongly 
recommended).

4 Choose Start ⇒ Programs ⇒ OSMF ⇒ Uninstall.

An Uninstall dialog box appears.  The uninstall process will automatically remove all OSMF 
application files, but you can also have the process remove newly created database files and all 
OSMF application log files by selecting the appropriate check-boxes in the dialog box.

5 After you have made any necessary selections in the Uninstall dialog box, click OK.
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6 Answer Yes to the question Are you sure you want to uninstall OSMF now?

Several terminal windows open and then close, then a �Confirm File Deletion� box appears 
which contains the message �Are you sure you want to completely remove 
the selected application and all of its components?�.

7 Select Yes in the �Confirm File Deletion� box.

8 When the box containing the message �Uninstall successfully completed� 
appears, click OK.

5.2.1.2 Install the Software
1 Log into the system as administrator, and enter the administrator password.

2 Exit all Windows programs that are currently running on the system (although this is not 
required, it is strongly recommended).

3 Insert the OSMF software install CD into the system�s local CD-ROM drive.

4 Start the Setup program:

a. Choose  Start ⇒ Programs ⇒ Windows NT Explorer.

b. Double-click on �Setup.exe� to start the OSMF setup program.

When the setup program (setup.exe) starts, it�s �Welcome� screen appears.

5 Read the information in the �Welcome� screen, click the Next > button and read the information 
in the �Information� screen that appears, then click the Next > button again to continue.

NOTE The �Information� screen might contain important information that does not appear in this 
manual.

6 Follow the instructions in the dialog boxes that ensue.

You will be prompted for the following information:

� Your Name and Company Name - The default in both fields for initial installations is HP, and 
these can be changed.

� Destination Folder -  The default is sys_drive:/osmf, and this can be changed if 
desired (sys_drive is typically the �c:� drive).

� Type Selection - You must choose Management Server for this installation.

After the above information has been entered, a �Check Setup Information� screen appears 
which contains a �Current Settings� scroll-box.  You can verify the setup information in this 
scroll-box.
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7 After you have verified the setup information in the �Current Settings� scroll-box, click the 
Next > button to start the install process.

When the install process starts, progress gauges appear which show the progress of the 
installation.  When the file installation completes, several message boxes appear, the last of 
which reads �Setup is Preparing Post Configuration...�

This message box might be followed by a question box which requires user action, or it might be 
followed by several terminal windows.  If a question box appears, continue with the next step.  If 
the question box does not appear, skip the next step and continue with step 9 after the terminal 
windows stop appearing.

8 If the svsec, svadm, svusr, svroot, or ora_dba groups exist on the system, you will be asked in a 
series of question boxes if you want to recreate each group.  You must click the appropriate 
button (Yes or No) in each question box.

NOTE These groups typically shouldn�t exist on a system on which you are performing an initial 
installation.  If they do exist, however, note that if you choose to recreate any group, all custom 
profile information for that group will be lost.

9 Remove the OSMF software install CD from the system�s local CD-ROM drive, as well as any 
other floppy disks or tapes that might be in the other system drives.

10 As the last step in the setup process, you will be asked if you want to reboot (restart) the system.  
Ensure that the �Yes, I want to restart my computer now� radio button is 
selected, then click Finish, to reboot the system.

NOTE After the system reboots, the sveht process might generate an exception error.  This is because 
the database has not yet been set up.  Ignore this error, and click OK in the message box to close 
it.

5.2.1.3 Set up the Database

CAUTION If you create a new database on a system that contains an existing OSMF database by performing 
the following steps, the entire existing database will be destroyed.  If you are upgrading or 
reinstalling the OSMF Management Server software, perform the procedure entitled  To Install 
the OSMF Management Server Software - Software Upgrades, rather than this one.

1 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Database Setup to 
start the database setup process.

When the process starts, a �svdbsetup� terminal window appears, and the following �SVdbsetup-
WARNING� message appears:
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This operation will create a fresh database for OSMF 3.0.  In the 
process it will delete all the files and data belonging to 
earlier installation of database for OSMF 3.0.

Do you want to continue this process?

2 Click the Yes button in the �SVdbsetup-WARNING� message box, then click Yes to the question 
�Are you really sure?,� to continue the database setup process.

As the database setup process starts, a �SVdbsetup - MESSAGE� box appears which shows the 
environments that are currently set in the registry table.

3 Click Yes in the �SVdbsetup - MESSAGE� box to continue.

Numerous messages appear in the �svdbsetup� terminal window as the database creation process 
proceeds.  Database creation can take a half hour or more.  As the database creation process nears 
completion, an �NNM Console Output Display� window appears, then an �SVdbsetup - 
MESSAGE� box appears which displays the message �Database setup is complete.�

4 Click OK in the �SVdbsetup - MESSAGE� box and close the �NNM Console Output Display� 
window.

5.2.1.4 Add Management Consoles to the Management Server�s 
Domain (if applicable)

1 Choose Start ⇒ Programs ⇒ Administrative Tools (Common) ⇒ Server Manager.

2 Perform the following steps for each Management Console in the installation:

a. Choose the Add to Domain... menu item from the Server Manager�s �Computer� menu to 
invoke the �Add Computer to Domain� dialog box.

b. Select the �Windows NT Workstation or Server� radio button.

c. Enter the name of the Management Console into the �Computer Name� field.

d. Click the Add button.

3 Close the Server Manager.

NOTE The domain name as well as the computer name should have been assigned as part of Windows 
NT installation and configuration on each computer.  If you do not know the name of a particular 
computer, perform the following on the computer:

- Choose Start ⇒ Settings ⇒ Control Panel, then double-click on the �Network� icon.
- Click the �Identification� tab.

The Computer Name and Domain name is shown on the �Identification� tab.
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5.2.1.5 Build the OSMF Graphics Modules
The following steps must be done in order for the OSMF software to correctly display the 
performance management-related screens.

1 Ensure that you are logged into the system as svroot.

2 Choose Start ⇒ Programs ⇒ Developer 2000 R2.1 ⇒ Graphics Builder to start the 
Oracle Graphics Builder.

3 In the Graphics Builder main window, choose Connect... from the File menu to invoke the 
Connect dialog box.

4 Enter the following information into the Connect dialog box, then click Connect:

� User Name - enter system
� Password - enter manager
� Database - enter sv30.servername.smartview.com

Where servername is the name of your computer.

5 In the Graphics Builder main window, choose Open... from the File menu, and click OK in 
the Filter dialog box that appears.

6 In the Open dialog box, choose the file perf_all.ogd in the OSMF\FORMS directory as the 
file to open.

7 If any Alert question boxes appear, click Yes.  The Layout Editor window will eventually appear.

8 In the Graphics Builder window, choose Compile All from the File menu.

If any errors appear in the Compile dialog box, click OK, close the file, save it, then perform 
steps 5 through 8 again until no errors appear.

9 After the file compiles with no errors, save it, close it, and perform steps 5 through 8 with files 
perf_cols.ogd, perf_curve.ogd, and perf_table.ogd.

5.2.1.6 Unlock the Deluxe Edition Functionality (if applicable).
The OSMF software that has now been installed contains the code for �Standard Edition� as well 
as �Deluxe Edition� features.  In order to use the software�s �Deluxe Edition� functionality, 
however, a license certificate must be obtained from HP.  The license certificate includes an 
alphanumeric license key code, which must be correctly entered in the following procedure in 
order to unlock the �Deluxe Edition� functionality.

NOTE The chapter entitled Introduction and General Information explains the features provided in both 
the standard edition and deluxe edition of the software.
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1 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Install License to 
invoke the �Install License� dialog box.

2 Enter the alphanumeric license key code exactly as it is shown on your license certificate into the 
�Enter New License Key� field, then click the Add button.

3 Verify that the key code is entered correctly by checking it in the �Installed Licenses� field of the 
dialog box, then click the Done button to close the dialog box.
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5.3 To Install the OSMF Management Server Software - Reinstallations
5.3.1 If you are reinstalling the same version of the OSMF Management Server software on your 
system, use the following procedure.

NOTES If you are reinstalling the software, perform the following procedure rather than the procedure 
for initial installations and upgrades, as the following procedure ensures that the database is 
preserved.

Before beginning the OSMF Management Server software installation, certain system 
requirements must be met, and the HP OpenView software and Oracle software must be properly 
installed and configured on your system.

Refer to the System Requirements section in the chapter entitled Introduction and General 
Information in this manual for a listing of the current hardware and software system 
requirements for a Management Server.  Refer to the appropriate HP OpenView and Oracle 
documentation for information on how to install the HP OpenView and Oracle software.

5.3.1.1 Back up the OSMF Database and HP OpenView Files
1 Log into the system as svroot.

2 Back up the current OSMF database and HP OpenView files.

Refer to the procedure entitled OSMF Database Backup Plus OpenView that is in the Backup 
Procedures section of the System Backup and Recovery chapter of this manual for more 
information.

3 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Database Services 
- Stop to shut down the OSMF database.

As the database is being shut down, a �svdbshut� terminal window appears which displays some 
status messages.  After the database shutdown process is complete, the �svdbshut� terminal 
window closes.

5.3.1.2 Remove the Existing Version of OSMF Software
1 Log into the system as svroot (if necessary).

2 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ System Monitor to 
ensure that no OSMF, HP OpenView NNM, or Oracle processes are running.

If these processes are not running, the Status Monitor will indicate that �OpenView Process 
Manager� and �Oracle TNSListner80� are STOPPED.  If no OSMF, HP OpenView 
NNM, or Oracle processes are running, close the System Monitor, then continue with the next 
step.  If any of these processes are running, perform the procedure entitled To Stop the OSMF 
Software and Database in the chapter entitled Starting and Stopping the OSMF Software before 
continuing with the next step.
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3 Close all OSMF application windows, and exit all Windows programs that are currently running 
on the system (although closing all Windows programs is not required, it is strongly 
recommended).

4 Choose Start ⇒ Programs ⇒ OSMF ⇒ Uninstall.

An Uninstall dialog box appears.  The uninstall process will automatically remove all OSMF 
application files, but you can also have the process remove newly created database files and all 
OSMF application log files by selecting the appropriate check-boxes in the dialog box.

5 After you have made any necessary selections in the Uninstall dialog box, click OK.

6 Answer Yes to the question Are you sure you want to uninstall OSMF now?

Several terminal windows open and then close, then a �Confirm File Deletion� box appears 
which contains the message �Are you sure you want to completely remove 
the selected application and all of its components?�.

7 Select Yes in the �Confirm File Deletion� box.

8 When the box containing the message �Uninstall successfully completed� 
appears, click OK.

5.3.1.3 Install the Software Upgrade
1 Insert the OSMF software install CD into the system�s local CD-ROM drive.

2 Start the Setup program:

a. Choose  Start ⇒ Programs ⇒ Windows NT Explorer.

b. Double-click on �Setup.exe� to start the OSMF setup program.

When the setup program (setup.exe) starts, it�s �Welcome� screen appears.

3 Read the information in the �Welcome� screen, click the Next > button and read the information 
in the �Information� screen that appears, then click the Next > button again to continue.

NOTE The �Information� screen might contain important information that does not appear in this 
manual.

4 Follow the instructions in the dialog boxes that ensue.

You will be prompted for the following information:

� Your Name and Company Name - These fields will contain the information previously 
entered during initial installation.  They can be changed now if desired.

� Destination Folder -  This field will contain the folder previously specified during initial 
installation.  It can be re-specified now if desired.
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� Type Selection - You must choose Management Server for this installation.

After the above information has been entered, a �Check Setup Information� screen appears 
which contains a �Current Settings� scroll-box.  You can verify the setup information in this 
scroll-box.

5 After you have verified the setup information in the  �Current Settings� scroll-box, click the 
Next > button to start the install process.

When the install process starts, progress gauges appear which show the progress of the 
installation.  When the file installation completes, several message boxes appear, the last of 
which reads �Setup is Preparing Post Configuration...�

This message box is then followed by a question box which requires user action.

6 You will be asked if you want to recreate each existing user group (svsec, svadm, svusr, svroot, 
and ora_dba) via a series of question boxes.  You must click the appropriate button (Yes or No) in 
each question box.

NOTE These user groups likely will already exist on a system that is being upgraded, and you therefore 
will likely be asked if you want to recreate all of them.  Note that if you choose to recreate any of 
these groups, all custom profile information for the group will be lost.

7 Remove the OSMF software install CD from the system�s local CD-ROM drive, as well as any 
other floppy disks or tapes that might be in the other system drives.

8 As the last step in the setup process, you will be asked if you want to reboot (restart) the system.  
Ensure that the �Yes, I want to restart my computer now� radio button is 
selected, then click Finish, to reboot the system.

5.3.1.4 Build the OSMF Graphics Modules
The following steps must be done in order for the OSMF software to correctly display the 
performance management-related screens.

1 Ensure that you are logged into the system as svroot.

2 Choose Start ⇒ Programs ⇒ Developer 2000 R2.1 ⇒ Graphics Builder to start the 
Oracle Graphics Builder.

3 In the Graphics Builder main window, choose Connect... from the File menu to invoke the 
Connect dialog box.

4 Enter the following information into the Connect dialog box, then click Connect:

� User Name - enter system
� Password - enter manager
� Database - enter sv30.servername.smartview.com
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Where servername is the name of your computer.

5 In the Graphics Builder main window, choose Open... from the File menu, and click OK in 
the Filter dialog box that appears.

6 In the Open dialog box, choose the file perf_all.ogd in the OSMF\FORMS directory as the 
file to open.

7 If any Alert question boxes appear, click Yes.  The Layout Editor window will eventually appear.

8 In the Graphics Builder window, choose Compile All from the File menu.

If any errors appear in the Compile dialog box, click OK, close the file, save it, then perform 
steps 5 through 8 again until no errors appear.

9 After the file compiles with no errors, save it, close it, and perform steps 5 through 8 with files 
perf_cols.ogd, perf_curve.ogd, and perf_table.ogd.

5.3.1.5 Unlock the Deluxe Edition Functionality (if applicable).
The OSMF software that has now been installed contains the code for �Standard Edition� as well 
as �Deluxe Edition� features.  In order to use the software�s �Deluxe Edition� functionality, 
however, a license certificate must be obtained from HP.  The license certificate includes an 
alphanumeric license key code, which must be correctly entered in the following procedure in 
order to unlock the �Deluxe Edition� functionality.

NOTE The chapter entitled Introduction and General Information explains the features provided in both 
the standard edition and deluxe edition of the software.

1 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Install License to 
invoke the �Install License� dialog box.

2 Enter the alphanumeric license key code exactly as it is shown on your license certificate into the 
�Enter New License Key� field, then click the Add button.

3 Verify that the key code is entered correctly by checking it in the �Installed Licenses� field of the 
dialog box, then click the Done button to close the dialog box.
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5.4 To Install the OSMF Management Client Software
5.4.1 If you are installing the OSMF Management Client software on your system for the first 
time, or if you are upgrading the Management Client software, use the following procedure.

NOTE Before beginning the OSMF Management Client software installation, certain system 
requirements must be met, and the HP OpenView software and Oracle software must be properly 
installed and configured on your system.

Refer to the System Requirements section in the chapter entitled Introduction and General 
Information in this manual for a listing of the current hardware and software system 
requirements for a Management Client.  Refer to the appropriate HP OpenView and Oracle 
documentation for information on how to install the HP OpenView and Oracle software.

5.4.1.1 Remove the Existing Version of OSMF Software (software 
upgrades only)

1 Log into the system as svroot, and enter the svroot password.

2 Close all OSMF application windows, then exit all Windows programs that are currently running 
on the system (although closing all Windows programs is not required, it is strongly 
recommended).

3 Choose Start ⇒ Programs ⇒ OSMF ⇒ Uninstall.

An Uninstall dialog box appears.  The uninstall process will automatically remove all OSMF 
application files, but you can also have the process remove newly created OSMF application log 
files by selecting the check-box in the dialog box.

4 After you have made any necessary selections in the Uninstall dialog box, click OK.

5 Answer Yes to the question Are you sure you want to uninstall OSMF now?

Several terminal windows open and then close, then a �Confirm File Deletion� box appears 
which contains the message �Are you sure you want to completely remove 
the selected application and all of its components?�.

6 Select Yes in the �Confirm File Deletion� box.

7 When the box containing the message �Uninstall successfully completed� 
appears, click OK.
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5.4.1.2 Install the Software (initial installations, reinstallations, 
and upgrades)

NOTE If you just completed the above procedure (Remove the Existing Version of OSMF Software), as 
when you are in the process of upgrading or reinstalling the software, you can skip the first two 
steps of the following procedure.

1 Log into the system as administrator (for initial installations), or svroot (for reinstallations and 
upgrades), and enter the appropriate password.

2 Exit all Windows programs that are currently running on the system (although closing all 
Windows programs is not required, it is strongly recommended).

3 Insert the OSMF software install CD into the system�s local CD-ROM drive.

4 Start the Setup program:

a. Choose  Start ⇒ Programs ⇒ Windows NT Explorer.

b. Double-click on �Setup.exe� to start the OSMF setup program.

When the setup program (setup.exe) starts, it�s �Welcome� screen appears.

5 Read the information in the �Welcome� screen, click the Next > button and read the information 
in the �Information� screen that appears, then click the Next > button again to continue.

NOTE The �Information� screen might contain important information that does not appear in this 
manual.

6 Follow the instructions in the dialog boxes that ensue.

You will be prompted for the following information:

� Your Name and Company Name - The default in both fields for initial installations is HP, and 
for software upgrades, the fields will contain the information previously entered.  In either 
case, they can be changed.

� Destination Folder -  The default is sys_drive:/osmf, for initial installations, and for 
software upgrades this field will contain the folder previously specified.  In either case, it can 
be changed if desired (sys_drive is typically the �c:� drive).

� Type Selection - You must choose Management Client for this installation.

After the above information has been entered, a �Check Setup Information� screen appears 
which contains a �Current Settings� scroll-box.  You can verify the setup information in this 
scroll-box.

7 After you have verified the setup information in the  �Current Settings� scroll-box, click the 
Next > button to start the install process.
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When the install process starts, progress gauges appear which show the progress of the 
installation.  When the file installation completes, several message boxes appear, the last of 
which reads �Setup is Preparing Post Configuration...�

This message box might be followed by a question box which requires user action, or it might be 
followed by several terminal windows.  If a question box appears, continue with the next step.  If 
the question box does not appear, skip the next step and continue with step 9 after the terminal 
windows stop appearing.

8 If the svsec, svadm, svusr, svroot, or ora_dba groups exist on the system, you will be asked in a 
series of question boxes if you want to recreate each group.  You must click the appropriate 
button (Yes or No) in each question box.

NOTE These groups typically shouldn�t exist on a system on which you are performing an initial 
installation, however, they likely will exist on a system that is being upgraded.  Note that if you 
choose to recreate any of these groups, all custom profile information for the group will be lost.

9 Remove the OSMF software install CD from the system�s local CD-ROM drive, as well as any 
other floppy disks or tapes that might be in the other system drives.

10 As the last step in the setup process, you will be asked if you want to reboot (restart) the system.  
Ensure that the �Yes, I want to restart my computer now� radio button is 
selected, then click Finish, to reboot the system.

5.4.1.3 Build the OSMF Graphics Modules
The following steps must be done in order for the OSMF software to correctly display the 
performance management-related screens.

1 Ensure that you are logged into the system as svroot.

2 Choose Start ⇒ Programs ⇒ Developer 2000 R2.1 ⇒ Graphics Builder to start the 
Oracle Graphics Builder.

3 In the Graphics Builder main window, choose Connect... from the File menu to invoke the 
Connect dialog box.

4 Enter the following information into the Connect dialog box, then click Connect:

� User Name - enter system
� Password - enter manager
� Database - enter sv30.servername.smartview.com

Where servername is the name of your computer.

5 In the Graphics Builder main window, choose Open... from the File menu, and click OK in 
the Filter dialog box that appears.
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6 In the Open dialog box, choose the file perf_all.ogd in the OSMF\FORMS directory as the 
file to open.

7 If any Alert question boxes appear, click Yes.  The Layout Editor window will eventually appear.

8 In the Graphics Builder window, choose Compile All from the File menu.

If any errors appear in the Compile dialog box, click OK, close the file, save it, then perform 
steps 5 through 8 again until no errors appear.

9 After the file compiles with no errors, save it, close it, and perform steps 5 through 8 with files 
perf_cols.ogd, perf_curve.ogd, and perf_table.ogd.

5.4.1.4 Unlock the Deluxe Edition Functionality (if applicable - 
initial installations and upgrades).
The OSMF software that has now been installed contains the code for �Standard Edition� as well 
as �Deluxe Edition� features.  In order to use the software�s �Deluxe Edition� functionality, 
however, a license certificate must be obtained from HP.  The license certificate includes an 
alphanumeric license key code, which must be correctly entered in the following procedure in 
order to unlock the �Deluxe Edition� functionality.

NOTE The chapter entitled Introduction and General Information explains the features provided in both 
the standard edition and deluxe edition of the software.

1 Choose Start ⇒ Programs ⇒ OSMF ⇒ System Administration ⇒ Install License to 
invoke the �Install License� dialog box.

2 Enter the alphanumeric license key code exactly as it is shown on your license certificate into the 
�Enter New License Key� field, then click the Add button.

3 Verify that the key code is entered correctly by checking it in the �Installed Licenses� field of the 
dialog box, then click the Done button to close the dialog box.
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6.1 In this Chapter
6.1.1 In order to establish communication between an SSU and the OSMF software, several 
parameters and switch settings must be set at the SSU.  The procedure in this chapter explains 
how to configure an SSU so that it can communicate with the OSMF software.
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6.2 To Configure SSUs to Communicate with the OSMF Software

Important The following steps suggest the order in which the SSU configuration should be performed.  For 
details on how to modify particular parameters, refer to the documentation supplied with the 
interface used (TL1 commands or local craft terminal).

6.2.1 Before any SSU can be managed by the OSMF software, some basic configuration is 
required on behalf of the system administrator.  Since the OSMF software cannot communicate 
with the SSU at this point, this configuration must be performed via an alternate interface.  Most 
of the parameters can be set using TL1 commands or via the local craft terminal.  Some switch 
settings will also have to be changed.  These switches are located on the NIMC assembly in the 
SSU.

NOTE Modification of some network parameters using TL1 commands requires that a sequence be 
followed that is different than for other parameters to avoid their inadvertently being changed.  
This sequence is explained in detail in the document entitled 55400A Supplemental 
Documentation that is shipped with the SSU.

1 Ensure that the "Security/Password Required" switch (bit 1 of switch S4 on the NIMC assembly) 
and the "Force Enable Local Port" switch (bit 3 of switch S4 on the NIMC assembly) is set to 
Off.

Refer to the figure at the end of this procedure for switch locations.

2 Create a user with name �svsec� and a security level of SECURITY with a password of up to ten 
characters.  The password must contain at least one special character (such as a period, asterisk, 
ampersand, or percent) and at least one non-alphabetical character. (The related TL1 commands 
are ED-USER-SECU (edit user security) and ENT-USER-SECU (enter user security).)

The password will later be used when managing the SSU using the OSMF software.

NOTE Refer to the 55400A SSU Programming Manual for information on creating the new user 
(�svsec�).

3 Verify that Remote Automatic Output is set to �ALWAYS� (the related TL1 keyword is 
RMTAO).

RMTAO determines the conditions under which automatic output messages are reported to the 
remote port.

4 Verify that Automatic Output Message Merge is set to �N� (the related TL1 keyword is 
AOMERGE).

AOMERGE determines whether or not commands and automatic output messages are merged 
onto the command port, or carried on separate ports.
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5 Set the following network parameters:

a. SSU IP Address - Change this to the IP address for the SSU being configured (the related 
TL1 keywords are IPNE (for working memory) and IPNEX (for auxiliary memory)).

b. OSMF Host IP Address - Change this to the IP address for the Management Server, that is, 
the system on which the OSMF database is running (the related TL1 keywords are IPEM1 
(for working memory) and IPEM1X (for auxiliary memory)).

c. Replication System IP Address - Ensure that this is set to 0.0.0.0 (the related TL1 
keywords are IPEM2 (for working memory) and IPEM2X (for auxiliary memory)).

NOTE If IPEM2 is set to a value other than 0.0.0.0 when a replication system is not installed, OSMF 
functional problems can result.  Replication is currently not available for the Windows NT 
version of the OSMF software.

d. Gateway Address - Change this to the IP address of the default gateway (The related TL1 
keywords are IPGATE (for working memory) and IPGATEX (for auxiliary memory)).

e. Sub-Network Address - Change this to the IP address of the sub-network mask (the related 
TL1 keywords are IPSUBNET (for working memory) and IPSUBNETX (for auxiliary 
memory)).

NOTE The following network parameters do not need to be changed from their default values to support 
OSMF software operation: Local Manager 1 Address (IPLM1, IPLM1X), Local Manager 2 
Address (IPLM2, IPLM2X), Command Port (PORTCMDS, PORTCMDSX), Auto Output Port 
(PORTAO, PORTAOX), and Inactivity Time (INACTTIME).

The following network parameters are obsolete: Port Bulk, Poll Time, Ack Time, Net Retry, and 
Net Timer 1.

6 Set "Scramble" to "Y" (the related TL1 keyword is SCRAMBLE).

Scramble determines whether or not communications from the SSU will be scrambled.

7 Ensure that the time and date is set at the SSU (The �ED-DAT� TL1 command can be used to set 
the time and date).

8 Set the "Enforce IPEM1/IPEM2/IPLM1/IPLM2 OR X25EM1/X25EM2" switch (bit 8 of switch 
S6 on the NIMC assembly) to Off.

When this switch is set to Off, the SSU will accept communications from any address.

NOTE If, as for security reasons, your situation requires that the SSU accept communication only from 
the defined set of addresses (IPEM1/IPEM2, IPLM1/IPLM2, X25EM1/X25EM2), bit 8 of 
switch S6 should be set to On.  When this switch is set to On, however, communications from all 
other addresses will be ignored, including Management Clients.
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9 Set "Security/Password Required" switch and "Force Enable Local Port" switch (bits 1 and 3 of 
switch S4 on the NIMC assembly) to On.

NOTE The SSU is now configured to communicate with the OSMF software.  It can now be added to a 
synchronization map.  When managing the SSU for the first time, you will need to enter its IP 
Address and Password.  The IP address to use is the one specified in step 5-a of the above 
procedure, and the Password is the one specified in step 2.

NIMC Assembly Switch Locations

S2

S1

S6

S5

S3
S4

O F F O N

1

8

S E C U R I T Y / P A S S W O R D
R E Q U I R E D

F O R C E  E N A B L E  L O C A L
P O R T
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